Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
softball24  
#1 Posted : Friday, January 9, 2015 12:54:27 PM(UTC)
softball24

Rank: Member

Groups: Registered
Joined: 1/9/2015(UTC)
Posts: 2

Our dishwasher is not getting water inside the unit. We replaced the water inlet valve and we can hear the water circulating, however it is not coming in to the unit. I am clueless when it comes to dishwashers as this was in the house when we moved here. Any ideas what else I can check?
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
denman  
#2 Posted : Saturday, January 10, 2015 8:47:33 AM(UTC)
denman

Rank: Advanced Member

Groups: Senior Expert
Joined: 2/29/2008(UTC)
Posts: 19,638

Was thanked: 10 time(s) in 10 post(s)
Here are your parts
Parts for Maytag MDBTT59AWW Dishwasher - AppliancePartsPros.com

[COLOR="Blue"]we can hear the water circulating, however it is not coming in to the unit.[/COLOR]
I am not sure what you mean by the above re: if there is no water in the unit I do not understand how you can hear it circulating?

If you open the door after the unit does a fill cycle is there water in the bottom of the tub?
There should be most units fill to just under the heating element.

Can you hear the water entering the tub?

Has the unit ever run OK for you?

Is there a separate water shut off on the water supply line?
If there is, is it open?
Perhaps the former owners shut it off as a safety measure.

If you loosen the supply line at the water valve does it start to drip?
If yes.
Then re-tighten the fitting and get a meter and check across the valve when it should be filling.
If there is 120 volts and there is no water flow into the dishwasher you may have a bad replacement valve.
THIS FORUM IS DEAD!!!!!!!
softball24  
#3 Posted : Saturday, January 10, 2015 9:14:16 AM(UTC)
softball24

Rank: Member

Groups: Registered
Joined: 1/9/2015(UTC)
Posts: 2

Got it working. The float was stuck.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.