Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.



Go to last post Go to first unread
#1 Posted : Tuesday, October 15, 2013 11:32:31 AM(UTC)

Rank: Member

Groups: Registered
Joined: 11/3/2010(UTC)
Posts: 2

My oven just set an F2E3 code, which means there is some kind of short or other issue with my control panel. The error actually occurred when I was trying to set the timer as I was putting something in the oven. The oven had heated properly, but after I pressed the timer--everything just seemed to go bad.

Anyhow, I have what is supposedly the OEM part number for a white control panel (4451261), but since this is a 17 year old oven, I can't seem to find any parts out there. Anyone have any places to suggest looking? Any way to try and repair the one I have?

The ironic thing is that I just updated my kitchen and didn't replace the oven since it was working fine--but I did run the self-clean cycle for the first time ever. I've since seen that Kitchenaid has had issues with this (on some lawyer's web site!). Don't know if it is related to my fault, and if it is, whether I have any recourse at this point.

Thanks for any suggestions.
See inside of your appliance - diagrams and part photos for virtually every model.

powered by
#2 Posted : Friday, October 18, 2013 2:41:02 AM(UTC)

Rank: Advanced Member

Groups: Senior Expert
Joined: 2/29/2008(UTC)
Posts: 19,638

Was thanked: 10 time(s) in 10 post(s)
Sorry but getting a keypad will be difficult.
I have no info on any site that actually sell used parts.

The problem may be in the keypad but also may be the control board.

Have you tried removing power from the unit for a couple minutes to see if it will reset.

Have you tried disconnecting the keypad to see if you get the same error. If you do then it is a control board problem.

A keypad with a shorted key is not repairable. Unfortunately they do not publish the key layout/output for stove keypads so it makes it difficult to diagnose. If it was a non essential key then you might be able to disconnect just that key to repair it but you need keypad info yo do this. A tech might be able to figure it out but it would take a lot of time.

I think this is a bubble keypad. You could try the following.
Put the keypad in an air tight bag.
Place it in a freezer overnight.
Then remove it from the freezer and let it warm up.
Using a hair dryer to heat it up may improve the chances of this working.
Then remove it from the bag and give it a try.

The reason for the bag is to keep condensation off the board as it warms up.

Sometimes the thermal expansion as it warms up will pop a bubble open again.
#3 Posted : Friday, October 18, 2013 4:41:25 AM(UTC)

Rank: Member

Groups: Registered
Joined: 11/3/2010(UTC)
Posts: 2

Thanks for the suggestions. I have removed power, removed the control panel, disconnected the ecu re-assembled. It then seemed okay for 2 minutes, then starting up with the display blacking out, then coming back on again in a somewhat random fashion, beeping all the while.

While it was functional (during those 2 minutes) I could use the whole keypad-- i.e. I reset the clock, set the oven to bake, etc.

This keypad is permanently attached to the control panel--so bagging/freezing this won't work.

Looks like I'll just have to shop fora new oven--and send Kitchenaid some feedback. I already had to replace the control pad in this unit about 5 years ago. Not what I consider quality, but I acknowledge I have had this 17 years.

I think
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.