Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.



Go to last post Go to first unread
#1 Posted : Monday, January 7, 2013 4:06:08 PM(UTC)

Rank: Member

Groups: Registered
Joined: 10/24/2012(UTC)
Posts: 8

HI All,

I have a early 90's GTI gas fireplace (off shoot of heat and glo). We bought a house and the wall switch has never worked with this unit so we just used the on/off rocker switch behind the access panel to make due. I started it up this winter and the switch no longer will do anything. The pilot flame lights and stays lit. I replaced the thermopile just to make sure it wasnt that and still having the same issue. Dug a little deeper and thought maybe the rocker switch was bad (maybe that was what was causing the wall switch not to work to). Bought one of those today and installed it with the black lead from terminal "A" to the "C" position double tap on the switch, that did not do it so I tried position "D" as well to no avail (cant remember which side it came off of when I unhooked the original switch.

I can jumper the top lead on the valve assembly (red terminals in pic, lead "A") to the gas valve lead "B" and the flame will come on. I had thought maybe we could just bypass the rocker switch and hook it directly to the wall switch but when I blew out the pilot the gas supply to it did not shut off so for safetys sake I dont want to go that route. So basically I am back at square one with a new thermopile and on/off switch installed. Anyone have any ideas as to what may cause the flame to not turn on? Seems to me it would be something simple as the gas valve is working and the thermopile is working. Would love to hear what you have to say "o' knowledgeable ones"

I attached pics showing connections.

lfreng attached the following image(s):
fireplace pic.jpg (56kb) downloaded 16 time(s).

You cannot view/download attachments. Try to login or register.
See inside of your appliance - diagrams and part photos for virtually every model.

powered by
#2 Posted : Tuesday, January 8, 2013 3:27:33 AM(UTC)

Rank: Member

Groups: Registered
Joined: 10/24/2012(UTC)
Posts: 8

figured it out with a schematic from a newer heat and glo. wire was missing between B and D. must have fallen off. all good now.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.