Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

3 Pages<123
Options
Go to last post Go to first unread
Gene  
#21 Posted : Wednesday, March 14, 2012 6:32:30 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

Originally Posted by: jsndsky Go to Quoted Post
I have replaced the board twice to the same result. The EOC will allow the heat relays to click on and off and the oven heats fine. But when I install either of the new eoc the relays do not function resulting in no heat. The indicator light above the temperature/mode knob comes on and the pre-heat light comes on but the relays do not function. If I put the old board in it heats correctly for 20 minutes then it beeps and F-1 is displayed. Was there a bad batch of boards?


What is the complete model number of the oven?

Gene.
jsndsky  
#22 Posted : Wednesday, March 14, 2012 6:53:13 PM(UTC)
jsndsky

Rank: Member

Groups: Registered
Joined: 8/8/2011(UTC)
Posts: 6

mef352bfda
jsndsky  
#23 Posted : Wednesday, March 14, 2012 7:00:24 PM(UTC)
jsndsky

Rank: Member

Groups: Registered
Joined: 8/8/2011(UTC)
Posts: 6

I have traced each wire for any shorts (for hours) and ran continuity test on each wire, from terminal on board to their proper location. I have tested the switches on the door lock motor (I get continuity when each switch activator is depressed) the motor currently sits where the top nip on wheel engages the top switch on door lock motor assembly leaving the bottom switch open. Just FYI's to help.
jsndsky  
#24 Posted : Wednesday, March 14, 2012 7:11:40 PM(UTC)
jsndsky

Rank: Member

Groups: Registered
Joined: 8/8/2011(UTC)
Posts: 6

When I unplug the probe I do immediately get the proper f3 error so it does recognize the probe. The light does come on and off as the door is used. Even though I ordered the boards a week apart both had the same date code 18-11. I would've like to have seen different date codes to alleviate the concern of a bad board run. I then came across several threads of others having the same issue when installing board # 316101103 with no conclusion to their threads.
Gene  
#25 Posted : Thursday, March 15, 2012 10:36:26 AM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

Where did you order them from?

Did you order and install the overlay together with the new clock/timer?

If you did not, then how you did it with the old one?

Gene.
jsndsky  
#26 Posted : Thursday, March 15, 2012 11:05:10 AM(UTC)
jsndsky

Rank: Member

Groups: Registered
Joined: 8/8/2011(UTC)
Posts: 6

Yes its an overlay, it does not plug into the board as a touchpad does. So im able to use the board with or without the overlay. The boards in its own plastic housing. Originally I was swapping the overlay back an forth then I just left it on one of the housings. So now I've tried each board several times and only the original board heat relays work with or without the relay. Do I need to wait a long time for the relays to work on new boards?
Gene  
#27 Posted : Thursday, March 15, 2012 11:16:04 AM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

So far I'm trying to find any information from Frigidaire regarding this clock. I will let you know as soon as I'll get any result.

Gene.
Adam / APP Team  
#28 Posted : Friday, March 16, 2012 11:04:50 AM(UTC)
Adam / APP Team

Rank: Administration

Groups: Administrators
Joined: 7/18/2007(UTC)
Posts: 214

I put in a research request to the manufacturer to find out why there have been random multiple complaints on the 316101103 board. This could take 2-7 business days to hear back from the manufacturer.

I have found the manufacturer has just replaced board part#316101103 with 316131601 this last month. Which leads me to believe they may now be aware of the problem and have fixed it since then.

Once I hear back from the manufacturer on a definite answer if all has been resolved I will update this post.

Thanks
jsndsky  
#29 Posted : Monday, March 19, 2012 5:12:44 AM(UTC)
jsndsky

Rank: Member

Groups: Registered
Joined: 8/8/2011(UTC)
Posts: 6

Thanks Gene!!!
Adam / APP Team  
#30 Posted : Thursday, March 22, 2012 10:45:36 AM(UTC)
Adam / APP Team

Rank: Administration

Groups: Administrators
Joined: 7/18/2007(UTC)
Posts: 214

jsndsky,

According to the manufacturer they have had no known issues reported or service bulletins out on this part.

At this point your best option is to get the replacement (316131601).

If you purchased it from us we can send out the warranty replacement to you at no extra charge.

All you will need to do is call our toll free number 1-877-477-7278 with your model and serial number and one of our qualified customer service representatives will take care of you quickly and easily.

Thank you for choosing AppliancePartsPros.com
Users browsing this topic
3 Pages<123
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.