Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

New Topic Post Reply
Options
Go to last post Go to first unread
FEFD17  
#1 Posted : Thursday, August 23, 2007 3:29:40 PM(UTC)
Quote
FEFD17

Rank: Member

Groups: Registered
Joined: 8/23/2007(UTC)
Posts: 2

Fisrt I want to say to anyone needing parts------GET THEM HERE!!! They are WAY cheaper than your local shop!!! trust me I took a beating on an Ignitor.....anyway

I bought these from your company the other day.

Part Number: AP2150379
Manufacturer's Number: 5303931775 (5303307291) made by FRIGIDAIRE

I have 115 volts to the gas valve.I have replaced the ignitor--the old one had a broken wire--I tried to take it out for soldering and it literally broke apart in my hand---figures....I had a lot of problem with no/little heat that is what started this mess.

I took the advice of a service man and he said to replace the coils--that they are common.I ordered them get them WAY faster than expected(me and the wife thank you for that)...I put it all together and now I get a bright orange glow,an audible click and nothing for heat.I have had it work somewhat maybe twice since I first put it together tonight.Since then I have faintly smelled gas and the other times I get very little heat.I do not see a lot of blue from flame while looking down thru the front lint catch..and even less heat.Here is a sequence for you that I have noticed.
1)Turn dryer on while watching from the front I see bright orange from the ignitor.
2)While the ignitor is hot I hear a click the ignitor goes out and I get/see very little blue from flame no heat and no actual hearing the burner taking off.....(when it was working correctly it was loud like a salamander heater)


I pulled the coils I purchased from you guys and I tested for continuity---no matter if it's the coil with three terminals or the coil with two I get NO continuity from either coil on any combination of terminals i try----I do NOT have continuity from the old coils either---so is it the coils are no good or something else? I have 116 volts at the gas valve At the input of the coils.I checked the flame switch for continuity and I do there as
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
FEFD17  
#2 Posted : Thursday, August 23, 2007 4:48:23 PM(UTC)
Quote
FEFD17

Rank: Member

Groups: Registered
Joined: 8/23/2007(UTC)
Posts: 2

just an update I pulled the front cover.I held a cloth in my hand and sarted the dryer.It lit the glowbar clicked the gas on and away it went.I put it all back together for the 151st time,started it,glowbar came on it clicked for gas glowbar went out and nothing for heat/gas/flameThe third time I pulled it back apart.Pulled the burner tube off,pulled out the gas orfice made sure it was clean--it was---put it all back together,started it up see the glowbar come on made a phone call,made a cup of coffee walked back in two minutes later tops and no click and the glowbar stayed on the whole time.


I am ready to unplug it,place in the front of ny truck and use it as a cushion in a demolition derby:mad:
Admin / APP Team  
#3 Posted : Friday, August 24, 2007 10:00:30 AM(UTC)
Quote
Admin / APP Team

Rank: Administration

Groups:
Joined: 7/18/2007(UTC)
Posts: 799

Was thanked: 1 time(s) in 1 post(s)
You're not going to like the answer...

The problem is most likely with the gas valve itself. It's not fully opening.

New valve is $175. Click here.
Quick Reply Show Quick Reply
Users browsing this topic
New Topic Post Reply
Forum Jump  
You can post new topics in this forum.
You can reply to topics in this forum.
You can delete your posts in this forum.
You can edit your posts in this forum.
You cannot create polls in this forum.
You can vote in polls in this forum.