Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
lenjack  
#1 Posted : Sunday, June 17, 2018 5:25:06 PM(UTC)
lenjack

Rank: Member

Groups: Registered
Joined: 6/17/2018(UTC)
Posts: 1

New user.

Wife's Frigidaire LGEF3033KWE refuses to bake. I checked and unit is receiving full 240VAC. Bake element shows 16.3 ohms resistance. Before I order a control board, is there anything else I should look at? I should point out that when we set to preheat, I can hear clicks, and the display shows the preheat temp, and the tiny leds light.
We've had it for 6 years with no problems. Thanks in advance.:(
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
dave6466  
#2 Posted : Tuesday, June 19, 2018 9:44:39 PM(UTC)
dave6466

Rank: Member

Groups: Registered
Joined: 6/1/2016(UTC)
Posts: 6

For some reason these convection ovens are hard on control boards. Changed out about 6 in the past year or so. Look closely on back of board where plug on connections are. If you see an area on board that looks brown or discolored there's a good chance that relay on board that sends power to bake element is bad. Relay on board will still click and display lights will still come on but contacts are scorched in relay. You need board #
316557236. Should be able to get one for around $85.00.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.