Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
swedespeed  
#1 Posted : Wednesday, April 4, 2018 6:01:02 PM(UTC)
swedespeed

Rank: Member

Groups: Registered
Joined: 4/4/2018(UTC)
Posts: 1

Hi all! Thanks in advance for reading about my issue. My parents have a Thermador Range Model PCG486GD/02. It has 4 burners on the left, a griddle in the middle, and 2 burners on the right. I've repaired it once already (1 unrelated burner not sparking).

Now, the two left-most burners are sparking nice and strong but are not lighting. The problem seems to be no gas flow. I can't hear the gas hissing out of the burner and I can't smell any gas either. The other 4 burners work fine. I'm thinking the solenoid gas valve, which would be this part. Do you guys agree? Also - and this may be a dumb question - but there's one solenoid for every burner, right? So I'd need 2 of them? I guess it seems unlikely that both solenoids would fail at the same time. Maybe it's something else?

Any other ideas? Thank you!
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.