Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
eingmund  
#1 Posted : Tuesday, February 20, 2018 7:12:07 AM(UTC)
eingmund

Rank: Member

Groups: Registered
Joined: 2/20/2018(UTC)
Posts: 1

I bought a house several months ago and this oven came with it. It's a GE profile electric oven / range. It has two ovens built into it, a large lower one and a small upper one.

We have found that whenever we try to cook something with it, the oven will just randomly shut itself off. Doesn't matter if you're using the upper oven or the lower one, it won't work reliably.

Here's what happens - I'll set the temp. Sometimes it preheats all the way. Other times the preheat cycle doesn't work and it shuts off before it has heated up to temp - like I said, it varies. When it goes off, I'll just see the clock display. No blinking (other than the two dots between the hour and minute), and NO error codes! I basically just keep watching it and resetting the temperature until dinner is done.

I've also noticed that sometimes when I press "0" to set the temperature (like to say, 300), the display will show the number "8" instead. Not sure if there is a connection there.

I just want some help with diagnosing it before I buy a 200+ dollar control board.
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.