Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
mindbender  
#1 Posted : Saturday, February 17, 2018 6:07:15 PM(UTC)
mindbender

Rank: Member

Groups: Registered
Joined: 2/17/2018(UTC)
Posts: 1

Kitchen Aid KGSC308LSS0 has an issue where it typically won't light the oven or broiler when warm or hot. Have replaced the igniters and sensor probe already. When oven is cold, hear the click sound indicating igniter coming on then a few seconds later the gas starts, heats up normally. Once the oven has been recently used or if trying to adjust temp up or down during use, the igniters don't engage. Have also previously had the issue where the display on the panel went out and I re-soldered the circuits. Wondering if there is also a circuit fault in the control board that needs repair.

Changed the igniters about 6 months ago as they were worn out and wouldn't heat quickly and caused the gas to build up when lighting. Just last week changed the sensor probe as the oven wouldn't start 90% of the time when cold.
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.