Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Tree_Farmer  
#1 Posted : Tuesday, October 24, 2017 2:45:13 PM(UTC)
Tree_Farmer

Rank: Member

Groups: Registered
Joined: 10/24/2017(UTC)
Posts: 1

I would like to ask for help in figuring out the problem with my oven.

It’s a Whirlpool, model: RBD276PDB1 It has 2 ovens, an upper and a lower one.

The problem is that the upper oven does not heat. The elements do not heat up. The bottom oven works fine.

Back to the top oven, The control panel seems to work. It let’s me turn on the oven, set Bake and temperature and turn On.

The light comes on when I open the door in the top one. The Door button seems to work, the light goes off when I push the door button.

I took out the bottom element and it does have continuity.

Can someone help me with troubleshooting? What should I test next?

Plus, How do you remove these from the cabinet? How do you pull out the oven, to check items in the back?

Thank you,
Larry
Tree_Farmer attached the following image(s):
Oven_Front copy.jpg (33kb) downloaded 1 time(s).
Oven_Control copy.JPG (127kb) downloaded 1 time(s).
Oven_Inside copy.JPG (135kb) downloaded 1 time(s).

You cannot view/download attachments. Try to login or register.
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.