Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
diy_dave54  
#1 Posted : Thursday, September 21, 2017 7:55:08 AM(UTC)
diy_dave54

Rank: Member

Groups: Registered
Joined: 9/21/2017(UTC)
Posts: 2

GE over the range microwave, model JNM3151DF1BB, 15 months old. Exhaust fan will not turn off, must unplug the unit after each use. Still heats food normally. I’ve replaced both thermostats on the bottom panel of the unit but the fan still runs continuously. I’ve tested all 3 door switches and they check out ok. I’m guessing the control board is bad, in which case I will probably replace the whole microwave rather than gamble on such an expensive part. But before I do that, is there anything else I should be testing? Thanks!
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
ThatGuy  
#2 Posted : Saturday, September 23, 2017 9:08:46 AM(UTC)
ThatGuy

Rank: Advanced Member

Groups: Expert
Joined: 7/27/2010(UTC)
Posts: 1,395

You probably have a suck relay on the board. You could repair or replace.

GE WB27X10931 Smart Board - AppliancePartsPros.com
diy_dave54  
#3 Posted : Sunday, September 24, 2017 3:51:57 AM(UTC)
diy_dave54

Rank: Member

Groups: Registered
Joined: 9/21/2017(UTC)
Posts: 2

Thanks, that's what I was afraid of. I'll probably just go ahead and buy a new microwave...this time with an extended warranty.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.