Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
wilkimtur1  
#1 Posted : Sunday, September 3, 2017 5:52:16 PM(UTC)
wilkimtur1

Rank: Member

Groups: Registered
Joined: 9/3/2017(UTC)
Posts: 3

My Roper washing machine stopped working after filling with water. It had worked fine with the previous load. After it stopped I tried moving to the rinse and spin cycle but these cycles would not work either. There was no noise coming from the machine, it just simply would not work. We did notice a smell of grease or burnt rubber. We checked the lid switch and that did not solve the problem. We have also replaced the drain pump within the last year as well as the motor coupler a few months ago. After leaving the washer sitting for a while it will work normally for a load but during use and immediately after the washer emits a strong smell of grease. We would like to repair this washer if possible rather than purchasing a new one but are not sure where to start or what the problem could be. Can anyone offer any advise with this problem?
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.