Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
pdpotts  
#1 Posted : Saturday, April 26, 2014 8:23:25 AM(UTC)
pdpotts

Rank: Member

Groups: Registered
Joined: 11/16/2013(UTC)
Posts: 3

My washer has started leaking. I removed the outer shell and started the washer. There was no leak as the tub filled. After the agitator started I saw a drip coming off a brace on the back of the frame, just under the tub. The brace is shaped like a channel and I could get my finger in the channel. I THINK the tub seal is leaking. Can you tell me if this is a reasonable assumption and what parts I might need to repair it.

Thanks,
Philip
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Users browsing this topic
Similar Topics
Kenmore washer leaking water on transmission (Washer Repair)
by arttruji 6/30/2016 11:55:27 AM(UTC)
Kenmore washer leaking at rinse cycle (Washer Repair)
by zeprulz 10/27/2009 3:05:52 PM(UTC)
Kenmore washer leaking under tub (Washer Repair)
by wjm7246 10/19/2009 6:31:02 AM(UTC)
kenmore washer leaking oil (Washer Repair)
by scottwalsh 3/25/2009 1:19:36 PM(UTC)
Kenmore washer leaking during agitation (Washer Repair)
by TK5028 1/11/2009 11:30:30 AM(UTC)
Kenmore Washer leaking (Washer Repair)
by danthebassman07 8/12/2008 1:22:41 PM(UTC)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.