Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
SteveXKR  
#1 Posted : Tuesday, October 20, 2009 9:17:45 AM(UTC)
SteveXKR

Rank: Member

Groups: Registered
Joined: 10/20/2009(UTC)
Posts: 1

Hi Everyone,


Moved into a house couple of months ago and it has a "HEIL" Brand natural Gas heater in our home. I've managed to find the following model number(s) on it:

model #GDe075b12a1
mfg# ndn6075f6a1
model# ndn6075fba1
Not sure when it's last been serviced.



it's been acting up lately where it'll be running and then all of a sudden basically blow cold air. When I go to look at it, the pilot light is lit, but
the burners don't come on, but the blower is running (and usually keeps running!).


If I turn off the power to the furnace i see the following 2 things happening
a) If I do a quick 'off-on' the pilot comes back on, but no ignition of the burners
b) if I leave it off for a little bit longer then the burners usually come on. There's 1 'rollout switch?' (is that what they're called?) up front, but it hasn't popped.



So I'm not sure if the problem is that a) the blower keeps running or b) that the burners come on or if they're related somehow, but either way with the cold weather coming it needs to be fixed asap! so any suggestions on what to look for and/or what i can do myself would be much appreciated!


Thank you
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.