Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
wingfieldteam  
#1 Posted : Saturday, August 24, 2013 1:06:40 PM(UTC)
wingfieldteam

Rank: Member

Groups: Registered
Joined: 8/24/2013(UTC)
Posts: 1

Hi,

I have a double oven and ran the cleaning cycle on the top oven. The oven works fine but the lights no longer work in either oven. Both lights in the ovens are out. Tried changing the bulbs to no avail. Any suggestions? Thanks.
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
HumboldtRepairMan  
#2 Posted : Saturday, August 24, 2013 2:01:36 PM(UTC)
HumboldtRepairMan

Rank: Member

Groups: Registered
Joined: 7/16/2013(UTC)
Posts: 916

Never use the clean cycle on your ranges people always have problems afterwards because it's gets too hot and damages things. Check the voltage where the lights go into see if you have 120v. If you don't check the door switches for continuity. If the switches check out ok examine your wiring from where the light sockets and follow that path look for burns/cracks/damaged wire or connections. You gave no model number so i can't advise on you can break down the oven. More then likely just remove the back panel pieces and start tracking the wiring from both lighting circuits. Good luck
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.