Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
AlabamaDan  
#1 Posted : Sunday, September 20, 2009 9:42:39 AM(UTC)
AlabamaDan

Rank: Member

Groups: Registered
Joined: 9/20/2009(UTC)
Posts: 3

This morning I went to use the stove. I turned on the oven and it started heating. When I went to turn on one of the stove top eyes, there was a click sound and then no more power. I checked the breaker in the house box and the plug looks fine. Is there some type of internal fuse or breaker? Can someone help me?
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
AlabamaDan  
#2 Posted : Monday, September 21, 2009 9:32:47 AM(UTC)
AlabamaDan

Rank: Member

Groups: Registered
Joined: 9/20/2009(UTC)
Posts: 3

Bump - needing help.
AlabamaDan  
#3 Posted : Monday, September 21, 2009 9:10:41 PM(UTC)
AlabamaDan

Rank: Member

Groups: Registered
Joined: 9/20/2009(UTC)
Posts: 3

took the panel off this afternoon, unplugged, looked around, reset the breaker, put it all back together, plugged it up and now it works, with the exception that the surface light indicator stays on even when the eyes are off.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.