Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
beachnik  
#1 Posted : Tuesday, July 24, 2012 12:12:44 PM(UTC)
beachnik

Rank: Member

Groups: Registered
Joined: 7/24/2012(UTC)
Posts: 1

I have Whirlpool range, model GW395LEGQ1, with 'oven' problems.

It's been working fine for years, suddenly without any previous peculiar behavior, the oven doesn't work. One day it worked, the next time it didn't work.

What should happen when using oven...
- Press the 'Bake' button
- LED control panel advises default temperature and says 'Bake'
- Press the 'Start' button - a half second later, you hear a electronic click from the area where the Control Panel is located (I presume it's opening a connection to the igniter - sending electricity to the igniter?)
- LED control panel advises that oven is going into Preheat Mode and starts Preheat countdown. Countdown is typically 10 minutes.
- After igniter heats up, you should just barely hear gas start to flow and oven burner ignites, preheat begins.
- After 10 minutes, preheat is completed, range sounds a tone to notify that oven is ready for use.

What is actually happening when attempting to use oven…
- Press the 'Bake' button
- LED control panel advises default temperature and says 'Bake'
- Press the 'Start' button - a half second later, you hear a electronic click from the area where the Control Panel is located.
- LED control panel advises that oven is going into Preheat Mode and starts Preheat countdown.
- Igniter does not glow
- Gas does not flow
- Although control panel counts down through the preheat time cycle - and gives the audible notification at the end of the time cycle, oven does not preheat, oven burner never ignites.

Miscellaneous...
- This model has the oven and broiler built into the same cabinet space. The broiler continues to operate normally.
- Everything on the LED control panel seems to be operating normally.
- The control panel does not display any error codes.
- The burners operate normally.
- Although it's 13 years old, the oven gets used about 15 times a year. The broiler gets used about 20 times a year. The only thing that looks used is the burner grates! Being a 'slide in' range, I'd hate to have to replace this beast.

Appreciate your comments.

Tags:
Whirlpool range model: GW395LEGQ1
Oven Ignitor pn: 9753108
Oven valve regulator pn: 9752698
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.