Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

8 Pages<12345>»
Options
Go to last post Go to first unread
Gene  
#21 Posted : Monday, February 4, 2008 1:44:13 AM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

I'm glad you were able to fix it.

Gene.
osgoodrp  
#22 Posted : Monday, June 2, 2008 6:30:59 PM(UTC)
osgoodrp

Rank: Member

Groups: Registered
Joined: 6/2/2008(UTC)
Posts: 3

Hi Gene,
I have a very similar issue with our advantium oven. Using the convection oven part and it just died in the middle of cooking. I found the diagram and it's the same as Nick's. My issue is how do I test the fuse (assuming I find it) and I can't see the diagrams linked to your post.
Gene  
#23 Posted : Monday, June 2, 2008 10:15:34 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

Click on any diagram link on page 1 and type your model number in the search box. You'll get all break down diagrams.

After you locate the fuse just check it for continuity (remove the wires first).

Gene.
osgoodrp  
#24 Posted : Tuesday, June 3, 2008 6:55:33 PM(UTC)
osgoodrp

Rank: Member

Groups: Registered
Joined: 6/2/2008(UTC)
Posts: 3

Thanks. Pulled the fuse and it's showing 0 on VOM, so I ordered the cavity thermocouple.
osgoodrp  
#25 Posted : Thursday, June 5, 2008 2:47:40 PM(UTC)
osgoodrp

Rank: Member

Groups: Registered
Joined: 6/2/2008(UTC)
Posts: 3

Got the part and installed it, we're back in business.

Many thanks from a greatful wife also.
Gene  
#26 Posted : Thursday, June 5, 2008 3:41:29 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

I'm glad you were able to fix it.

Gene.
FlockWSO  
#27 Posted : Sunday, August 24, 2008 3:28:41 PM(UTC)
FlockWSO

Rank: Member

Groups: Registered
Joined: 8/24/2008(UTC)
Posts: 2

I'm glad I found this forum! I also have a dead Kenmore Elite Advantium 120 - Model 363.63699301. I understand this model may be different than those already mentioned in this thread, but after looking at the diagrams they appear fairly similar.

Anyway, I was using the convection oven when it just stopped - no display, no light, nothing. The power going to the oven power cord checks ok, so the issue is within the unit.

Based on the previous repairs in this thread, it looks like I need to take the unit off the wall, check the fuse, and if the fuse is ok I should replace the themocoupler, right? Based on my parts list and diagrams, I see a "TCO, Oven Cavity" and a "TCO, Base Hood." Is the Oven Cavity the one I should repace? Is there a way to bench check a TCO? With a manual and some tools I am fairly handy with disassembly/assembly, but I can certainly use a primer on how the parts work together.

Any help is appreciated!
FlockWSO  
#28 Posted : Sunday, September 7, 2008 6:23:59 PM(UTC)
FlockWSO

Rank: Member

Groups: Registered
Joined: 8/24/2008(UTC)
Posts: 2

Well, even though I didn't get a reply here, I took the plunge and bought the TCO. Taking the oven off the wall and then tearing into it wasn't fun, but the "operation" was ultimately successful. There certainly were a lot of layers to disassemble to get to the part I needed to swap, but in the end it was pretty straight forward.

So thanks for the previous postings here - it gave me the confidence to perform this surgery on my own!
kenmoreuser1  
#29 Posted : Monday, September 8, 2008 11:44:36 AM(UTC)
kenmoreuser1

Rank: Member

Groups: Registered
Joined: 9/8/2008(UTC)
Posts: 1

After reviewing all the issues here, it should steamline my troubleshooting. I'll post if it works.

Thanks All
Strummer  
#30 Posted : Sunday, October 12, 2008 4:47:38 PM(UTC)
Strummer

Rank: Member

Groups: Registered
Joined: 10/12/2008(UTC)
Posts: 1

I have the same issue, do I have to take it of the wall to check the fuse?
Users browsing this topic
8 Pages<12345>»
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.