Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
ashford  
#1 Posted : Friday, May 15, 2009 9:37:18 AM(UTC)
ashford

Rank: Member

Groups: Registered
Joined: 5/12/2009(UTC)
Posts: 5

All 5 stove won't ignite, no clicking sound heard. Gas can be heard, electrical outlet is working and is plugged. Spark module replaced, still not working and instead lock/unlock switch sparked when turned. What other parts do I need to repair this stove. Thanks
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Gene  
#2 Posted : Friday, May 15, 2009 5:24:18 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

Which part did you call "lock/unlock switch"?

If the spark module is new then most likely the problem is a bad switch harness.

- The part number for the switch harness is AP3860449

Here are the breakdown diagrams and Replacement parts for GE JGP970SEK1SS | AppliancePartsPros.com

Gene.
ashford  
#3 Posted : Sunday, May 17, 2009 12:44:34 PM(UTC)
ashford

Rank: Member

Groups: Registered
Joined: 5/12/2009(UTC)
Posts: 5

The lock/unlock key or sel knob, part id #40, sparked when turned.
Do you think there might be other problems?
I have ordered the harness switch, it should arrive next week.
I will replace it when it arrived. I have also ordered the harness wire burner since that one is out of stock and might take 1-6 weeks to arrive, just in case the stove still doesnt ignite after replacing the harness switch. Thank you for responding, greatly appreciated.
Gene  
#4 Posted : Sunday, May 17, 2009 3:41:26 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

Originally Posted by: ashford Go to Quoted Post
...The lock/unlock key or sel knob, part id #40, sparked when turned.
Do you think there might be other problems?...


You will see it when you'll take it apart. Keep us posted.

Gene.
ashford  
#5 Posted : Friday, May 22, 2009 12:15:28 PM(UTC)
ashford

Rank: Member

Groups: Registered
Joined: 5/12/2009(UTC)
Posts: 5

:) I have installed the harness switch and it's working - sparking or igniting :( but now the red light is on and it is buzzing loud continuously and if you lock it, it is still igniting. Lock or unlock, unit is still turning on when turned, red light is on and buzzing continues. :confused: What is wrong now? I need help.
Gene  
#6 Posted : Friday, May 22, 2009 3:47:04 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

I'm not able to help you with this issue without the wiring diagram for this stove which I can not find online. If you do have one and can post it then it might help.

Gene.
ashford  
#7 Posted : Saturday, May 23, 2009 12:06:16 AM(UTC)
ashford

Rank: Member

Groups: Registered
Joined: 5/12/2009(UTC)
Posts: 5

Thank you for letting me know. I tried to search it online, one says to check each unit one at a time if they are working. Red light may indicate that a unit is not working. I will try this and will let you know. I'm getting frustrated to a point that I might go ahead and buy a new less expensive and less complicated unit. But Im still going to give it a shot again. Wish me luck. Have a good long weekend.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.