Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
danh  
#1 Posted : Saturday, November 29, 2008 2:09:48 PM(UTC)
danh

Rank: Member

Groups: Registered
Joined: 11/29/2008(UTC)
Posts: 1

The oven and broiler won't light even if you hold a match to them. The top burners seem to work ok. Any suggestions will be appreciated.
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
libertyappl  
#2 Posted : Sunday, November 30, 2008 6:08:55 AM(UTC)
libertyappl

Rank: Advanced Member

Groups: Senior Expert
Joined: 8/13/2008(UTC)
Posts: 3,097

The most common problem is the ignitor is out. I'm unable to pull up the model number posted.

Nat
kayakcrzy  
#3 Posted : Sunday, November 30, 2008 7:57:53 AM(UTC)
kayakcrzy

Rank: Advanced Member

Groups: Senior Expert
Joined: 2/1/2008(UTC)
Posts: 2,429

If this is a older tappan, you will have a burning pilot flame. If you take the bottom of the oven floor out, so you can see the pilot assembly, which is the burning pilot flame. When you turn on the oven the flame should jump, and hit the little metal wire that is coming from the gas valve. Sometimes the lines get full of gas residue, and the flame does not jump far enough to hit the end of the sensor. So what you have to do is cheat time. So the end of the sensor, had a small straight screw that holds it in place. losen the screw and take the sensor out. Now turn the oven on and see how far the flame jumps, and bend the sensor to stay in the spot where the flame jumps too. Leave it there for a minute, and see if the oven comes on. You might have to move it a few times to get it in the right spot. Let me know how it goes. Tom ApplianceEducator.com
marcisikoff  
#4 Posted : Friday, October 12, 2012 7:40:36 AM(UTC)
marcisikoff

Rank: Member

Groups: Registered
Joined: 10/12/2012(UTC)
Posts: 1

Saw that post above and I can see my Tappan (model: -MPF300PXWG):

1. Oven control definitely gets the pilot light to go higher. Stay higher as long as oven control is not OFF. Pilot light much stronger.

2. No ignition of gas takes place to the oven. I have taken out the oven bottom and seen how high the pilot gets, and it definitely gets to the gas pipe running front to back.

3. So I'm guessing there's no gas flowing in that pipe else it definitely would ignite. [Note: I've removed the spreader and oven base and cleaned them of debris, soot, etc].

4. Takes me back to the oven control behind the oven knob under the stove top panel. It has 3 lines out of it (1 is thermostat into the oven, 1 is control for the pilot light to go higher, 3rd I'm not sure but guess it's gas control related?)

So I'm stuck with 4 working burners, and no oven. Not sure what to replace.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.