Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

New Topic Post Reply
Options
Go to last post Go to first unread
wang246  
#1 Posted : Tuesday, October 19, 2021 7:01:58 PM(UTC)
Quote
wang246

Rank: Member

Groups: Registered
Joined: 10/19/2021(UTC)
Posts: 0
United States

Hello,

I have a problem with my evaporator being covered in ice. Here is my story so far.

In September 2021 I replaced the water inlet valve because water was trickling into the ice maker tray when it wasn't calling for water. The ice mold tray overflowed and it froze and there were icicles all over the inside of the freezer compartment. I replaced the water inlet valve and the water leaking into the ice tray was solved but the ice maker was no longer making ice so I thought maybe when the water overflowed it might have damaged the ice maker controls. I replaced the ice maker as well and it was working properly again.

Now, a month later in October, I have this new issue I noticed since 10/15/21 where the freezer and fridge side both had higher than normal temperatures even though the food and ice was still frozen and the fresh food was still cool but not as cool as it should be. This is when I started checking basic things like the condenser coils, condenser fan, and evaporator fan. I cleaned the condenser coil as best as possible and verified the two fans were spinning. When checking the evaporator fan, I noticed that the evaporator was frozen in ice. This is when I checked the defrost thermostat and the defrost heater and both had continuity. Does my previous problem with the ice maker and water inlet valve have anything to do with this current problem?

After checking all those parts I chatted with Appliance Pro Support on 10/19/21 and they suggested maybe the control board is bad but it's no longer available. I found some third parties online selling or repairing these boards but I still wasn't sure if this would solve my issue. Support was also kind enough to give me the service and wiring sheet in order to perform the onboard diagnostics using the temperature control panel. So when I got home from work I went through all the diagnostics and they all passed including step 7 which was to activate the heater to melt the ice. I activated step 7 and visually saw the ice melting from the evaporator so I'm confused on what my actual issue is that caused the ice to form to begin with. If the control board was bad, how was I able to perform step 7 to activate the heater? If I was able to get the ice to melt from the diagnosis step 7, doesn't that mean the heater, defrost thermostat, and control board are all working properly? I'm actually more confused now and could use some more advice please?


Thank you.
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
denman  
#2 Posted : Wednesday, October 20, 2021 5:34:56 AM(UTC)
Quote
denman

Rank: Advanced Member

Groups: Senior Expert
Joined: 2/29/2008(UTC)
Posts: 19,638

Was thanked: 11 time(s) in 11 post(s)
Yes it means that the defrost heater and defrost thermostat are OK.

It also means that you can force a defrost cycle on the board.
It does not mean that the board will preform an automatic defrost.
So odds are the board is bad.
THIS FORUM IS DEAD!!!!!!!
wang246  
#3 Posted : Wednesday, October 20, 2021 8:42:10 AM(UTC)
Quote
wang246

Rank: Member

Groups: Registered
Joined: 10/19/2021(UTC)
Posts: 0
United States

Hi Denman,

Thanks for your advice but it got more confusing this morning. Last night when I manually did the defrost it was just for a few minutes but I could see the ice melt and drip down the drain hole into the pan under the freezer side. Since it was only for a few minutes, there wasn't much water in the pan and before I went to bed it was pretty much all evaporated already. This morning I checked the pan and there was a pool of water like normal when the defrost was working like normal. I checked inside the freezer and looked at the bottom rear of the back wall panel and I can see the bottom of the evaporator coil. I could see that it defrosted because there was little to no frost compared to the night before when I manually defrosted. So, now I'm not sure if this all of a sudden started working properly after I did the diagnostic tests or if this is still an issue and it's an intermittent issue? Any thoughts?
denman  
#4 Posted : Thursday, October 21, 2021 2:34:56 AM(UTC)
Quote
denman

Rank: Advanced Member

Groups: Senior Expert
Joined: 2/29/2008(UTC)
Posts: 19,638

Was thanked: 11 time(s) in 11 post(s)
Cannot be sure what has happened.

Is it possible that you shut the unit off/unplugged it.
Sometimes that can clear a fault on a control board just like a computer etc.
THIS FORUM IS DEAD!!!!!!!
wang246  
#5 Posted : Thursday, October 21, 2021 6:49:19 AM(UTC)
Quote
wang246

Rank: Member

Groups: Registered
Joined: 10/19/2021(UTC)
Posts: 0
United States

I unplugged it on Monday night 10/18/21 when I was doing my original tests which led me to finding the evaporator covered in ice. Tuesday night 10/19/21 is when I performed the onboard diagnostics using the control display in the fresh food side. I did not unplug the fridge this day. Wednesday morning 10/20/21 is when I noticed that it had defrosted on its own. Today, Thursday morning 10/21/21 I did not notice water in the pan and the coil does not look like it's defrosted. Is there supposed to be a certain time of day it's supposed to defrost like on a schedule? Or does it just know when it's supposed to defrost and the days and times vary all the time?
Guest  
#6 Posted : Thursday, October 21, 2021 1:13:20 PM(UTC)
Quote
Guest

Rank: Guest

Groups:
Joined: 8/10/2018(UTC)
Posts: 0
United States
Location: 99556

Was thanked: 1 time(s) in 1 post(s)
Since it is controlled by a board it will vary.
Different units use different defrost schemes some use the number of times the door opens but others are much more complex.
Quick Reply Show Quick Reply
Users browsing this topic
New Topic Post Reply
Forum Jump  
You can post new topics in this forum.
You can reply to topics in this forum.
You can delete your posts in this forum.
You can edit your posts in this forum.
You cannot create polls in this forum.
You can vote in polls in this forum.