Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
digglife  
#1 Posted : Tuesday, September 1, 2009 4:54:23 PM(UTC)
digglife

Rank: Member

Groups: Registered
Joined: 9/1/2009(UTC)
Posts: 2

Hey guys, I have a Frigidaire Gallery Pro electric smoothtop range. One of the back (small size) elements no longer works. Called for service, they want $90 diagnostic fee plus $272 on top for the labor and part cost. Thats a lot of dough!! I have sourced the element at $140 .. wondering if its really a lot of trouble to put one in myself? The range is about 3 years old and in good condition, but I miss not having the element around ... I am reasonably technical and have built my own electronics projects in the past, but have never opened up an appliance before.
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
digglife  
#2 Posted : Friday, September 4, 2009 3:02:18 PM(UTC)
digglife

Rank: Member

Groups: Registered
Joined: 9/1/2009(UTC)
Posts: 2

No one has any ideas?
Gene  
#3 Posted : Friday, September 4, 2009 5:24:37 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

Does it show any error code on the display for this burner?

The model number you posted is incomplete. Verify and repost it.

Gene.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.