Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Post a reply
From:
Message:

Maximum number of characters in each post is: 32767
Bold Italic Underline   Highlight Quote Choose Language for Syntax Highlighting Insert Image Create Link   Unordered List Ordered List   Left Justify Center Justify Right Justify   Outdent Indent   More BBCode Tags
Font Color Font Size
Security Image:
Enter The Letters From The Security Image:
  Preview Post Cancel

Last 10 Posts (In reverse order)
mike_balt Posted: Thursday, May 9, 2024 7:00:09 PM(UTC)
 
appreciate the thoughts . seems like the whole control board is available for $7-800 but at that point, have to wonder about just replacing the whole oven.
WilliamM/APP Team Posted: Tuesday, May 7, 2024 7:21:47 AM(UTC)
 
Mike_balt, the error F- is going to indicate a communication error detected by the main relay board. This can be caused by a failing display control or relay control. The wire connections would need to be checked for any loose connections. If the connections are not loose, it would likely be a failure in the display control. Unfortunately, the repair kit 00702451 has been discontinued and is no longer available.
mike_balt Posted: Monday, May 6, 2024 4:16:42 PM(UTC)
 
we have a Thermador double oven circa 1999 (SCD302TP) . it works fine, but lately, about 10 min after we use it and turn it off, it will start beeping and looks like it's trying to throw an error code, but all that part of the display says is "F-" I think when there's an error, it's supposed to say F and a number (like F3), but all I get is a dash (F-).

while beeping, I can hit end and the beeping will stop for about a minute, then it will continue. If I throw the breaker for a short period of time (like 30 seconds), it will start beeping again in about a minute or so. if I throw the breaker for a while (like 15 min) the beeping stops and it goes back to normal (not sure if that's because it resets or if the problem is a heat related one and the 15 min is enough time to make whatever is throwing the error happy.

any thoughts?
is this a heat switch related issue? a motherboard?