Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.



Post a reply

Maximum number of characters in each post is: 32767
Bold Italic Underline   Highlight Quote Choose Language for Syntax Highlighting Insert Image Create Link   Unordered List Ordered List   Left Justify Center Justify Right Justify   Outdent Indent   More BBCode Tags
Font Color Font Size
Security Image:
Enter The Letters From The Security Image:
  Preview Post Cancel

Last 10 Posts (In reverse order)
Guest Posted: Sunday, September 10, 2023 1:17:24 PM(UTC)
In checking some of the obvious things which I overlooked since the relay was bad I found the thermal fuse was open circuit. I replaced it and with the newer K1 relay the unit is now up and running. It pays to look at the simple things and not take anything for granted.
Guest Posted: Sunday, September 10, 2023 8:31:04 AM(UTC)
Since I had nothing to loose I took the K1 relay off of the revision D board and put it on the revision C board to see if it would work. It did not and the results were the same - A click of the K1 relay but no other power going into the motor or the heater so I will likely have to replace the circuit board. I noted that there are some of these circuit boards listed on E Bay and I may try one of these.
Guest Posted: Saturday, September 9, 2023 9:26:30 AM(UTC)
I was given the above model dryer with s/n MU5142547 with the complaint that it would not turn on . The display shows an F01 code. According to what I can find this is a typical problem in the Control panel with relay K1. I removed the panel and found a burned connector pin at one of the 4 pins on the underside of the panel for this relay. I tried resoldering this pin connection but it did not do any good. When I reconnect all the wires and plug it back in to the power, it will not start and makes a slight click in the K1 relay. I had another control panel from a Duet dryer in my junk box that was saved from another dryer and all the pin solder joints were in good condition for relay K1. It was installed but nothing worked at all when I tried to get it to start. I noted that this board has an extra small relay at position K4 . The board is p/n 6105034 (rev D ) as compared to the original board which is 6105034 (rev C) The rev D board also has another item on the board at location L4 as compared to the original rev C board which does not. I cannot see any connector pins on the underside of the panel for these devices.
I am considering removing the relay K1 from the Rev D board and using it in place of the same item from the revision C board. Does anyone out there have some other helpful suggestions to make this dryer work ? The complete panel is no longer available as a replacement part. HELP !