Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Post a reply
From:
Message:

Maximum number of characters in each post is: 32767
Bold Italic Underline   Highlight Quote Choose Language for Syntax Highlighting Insert Image Create Link   Unordered List Ordered List   Left Justify Center Justify Right Justify   Outdent Indent   More BBCode Tags
Font Color Font Size
Security Image:
Enter The Letters From The Security Image:
  Preview Post Cancel

Last 10 Posts (In reverse order)
coachroy Posted: Friday, October 16, 2020 10:58:40 AM(UTC)
 
So I feel like I have tested everything and have had no luck. The dryer works but does not heat. I was able to narrow it down to what I thought was the switch on the motor because when I would play around with it, I was able to get the heating element to heat up but then after a bit I was no longer able to. All my fuses are reading continuity and the element is reading 10.4ohms with power off. When I turn power on, It reads 119-120v. I checked the relay. With power off only one lead received 119.1 and with power on they both read 119.1. The fuses on the blower casing are also reading fine as well. I've even tried putting in new fuses and still no luck. I've taken apart the heating element to inspect the wires and they are all intact. Can someone point me in the right direction? Im wondering if I was sent a broken switch on the motor.