Customer Support 7 days a week

Welcome Guest! You can not login or register.

Notification

Icon
Error

Post a reply
From:
Message:

Maximum number of characters in each post is: 32767
Bold Italic Underline   Highlight Quote Choose Language for Syntax Highlighting Insert Image Create Link   Unordered List Ordered List   Left Justify Center Justify Right Justify   Outdent Indent   More BBCode Tags
Font Color Font Size
Security Image:
Enter The Letters From The Security Image:
  Preview Post Cancel

Last 10 Posts (In reverse order)
denman Posted: Tuesday, September 1, 2015 2:58:57 AM(UTC)
 
Here are your parts
Parts for Whirlpool RBS305PDB12 Oven - AppliancePartsPros.com

See the attachment for the tech sheet

Could be that the thermal overload (item 37 in section 01) has blown.
Check it with a meter.

If blown replace it then carefully monitor the oven's operation as a bad control board may have caused the original problem.

Also possible that you are not getting the full 240 volts.
Try flipping the breaker off/on slowly a couple times.
If still no go check the power with a meter.

If it is OK then odds are that the control board is bad.
THIS FORUM IS DEAD!!!!!!!
BIG THUNDER Posted: Monday, August 31, 2015 6:09:23 AM(UTC)
 
I have a built-in Whirlpool electric single wall oven (RBS305PDB12) that is misbehaving. My wife said she turned the oven on to preheat, but I noticed that it was self cleaning and that the door was locked. This situation has happened several times before and I have always blamed her for hitting the wrong buttons, but she insists that she doesn't do anything wrong and that there is something wrong with the oven.
At any rate, I hit the OFF/CANCEL button and the display indicated that it was off. But I soon noticed that the broil element was still on. I then turned the breaker off and waited for the oven to cool down enough that the door could be opened.
When I eventually turned the breaker back on, the door was unlocked and everything looked normal. I reset the clock and thought all was well. I later turned the oven on to bake preheat and the blower started and the display indicated that it was preheating. However, i soon discovered that the element did not heat at all. I then tried broil with the same results.
Any help would be greatly appreciated. Thanks.