Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.



Post a reply

Maximum number of characters in each post is: 32767
Bold Italic Underline   Highlight Quote Choose Language for Syntax Highlighting Insert Image Create Link   Unordered List Ordered List   Left Justify Center Justify Right Justify   Outdent Indent   More BBCode Tags
Font Color Font Size
Security Image:
Enter The Letters From The Security Image:
  Preview Post Cancel

Last 10 Posts (In reverse order)
Liam569 Posted: Thursday, May 23, 2019 3:18:58 AM(UTC)
In your case, the only replacement will help.
wjob Posted: Sunday, March 2, 2014 8:30:35 AM(UTC)
Was able to free it up by going in from the top with a pry bar. Worked fine until now, have the same problem again. Will probably wind up replacing it.
oldtrail Posted: Wednesday, January 29, 2014 5:50:14 PM(UTC)
I would remove to look into without rubber gasket in place. maybe age has taken it's toll. If nothing can be seen and cannot dislodge, get a new one, save the headaches.
sylvia132 Posted: Monday, January 13, 2014 6:05:33 PM(UTC)
If you follow the link the answer is still not spelt out - its only there by inference! I'm littering the place with replies to try and get onto where I want to and put something useful there!!! Frustrated with this already. It is my honor to find this article. I would like to thank you for your best written post, its informative and your writing style helped me to read it till end. Thanks man!
wjob Posted: Saturday, January 11, 2014 9:15:58 AM(UTC)
This is stuck fast. Have tried the tool in the bottom and attacking from the top with a heavy piece of wood, but won't move at all, in either direction? Now considering putting an extension over the tool so I can apply some real leverage at the botttom? Can't see anything that is stuck?

Suggestions please?