Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.



Post a reply

Maximum number of characters in each post is: 32767
Bold Italic Underline   Highlight Quote Choose Language for Syntax Highlighting Insert Image Create Link   Unordered List Ordered List   Left Justify Center Justify Right Justify   Outdent Indent   More BBCode Tags
Font Color Font Size
Security Image:
Enter The Letters From The Security Image:
  Preview Post Cancel

Last 10 Posts (In reverse order)
Viejoaz Posted: Monday, June 29, 2020 3:24:28 PM(UTC)
Whirlpool range/oven
Slide in 4.8 touch control ss.
No power, control panel dead. 3 3 Months after purchase c.panel would go dead. 2-3 hours back on. After 2nd occurrence, service replaced control board.
Now c.panel dead for 48 hours. Circuit breaker reset, 200 v at wall outlet and unit terminal block.
safletcher Posted: Friday, January 12, 2018 3:24:46 AM(UTC)
Fix Your Board did the refurb.

I cleaned the ribbon connecting the touchpad to the control board. The beeping stopped and we got an E1F2 error code. Replacing the keypad now...
Gene Posted: Thursday, January 11, 2018 11:06:15 PM(UTC)
Originally Posted by: safletcher Go to Quoted Post
I had my control board refurbished...

Who did it?

Double check the wire harness and touchpad connections. If they fine, the control board is bad.
safletcher Posted: Wednesday, January 10, 2018 7:20:01 PM(UTC)
I had my control board refurbished and installed it tonight. Upon turning the power back on, the unit goes into a pattern of seven short beeps followed by a brief pause. I tried the key sequence for programming the board for the correct oven cavity, but that isn't working. The oven goes into "timed cook" mode and reverts back to beeping after I cancel. Any ideas?
gregdavis11009 Posted: Thursday, October 12, 2017 11:56:11 AM(UTC)
Hey Kafansler,

Try this link for your model (RBD305PDB12):

gregdavis11009 Posted: Thursday, October 12, 2017 11:40:45 AM(UTC)
I had to go onto the chat window but the Sears agent was able to find the part for the control panel (the black one) base on my oven model number (GBD277PDS09). $212.34 including shipping & tax. Good luck! Posted: Thursday, June 30, 2016 4:11:39 PM(UTC)
Yesterday we used self-clean cycle of oven. The temperature was very high, so after few hours the door of oven locked. we wait to be cool but it doesn't open till now! the display doesn't show anything. We pull out oven from the cabinet and opened the back of oven. my question is how can I bypass the fuze? and remove the fuze? Actually I don't know what happened after self-clean! Would you please help me.
Kafansler Posted: Thursday, November 26, 2015 9:24:39 AM(UTC)
I have a Whirlpool double wall oven with intermittent error code E6 F2. Sometimes the ovens work and then sometimes they won't. After reading the above posts I think it is probably a control board going out. I have looked and can't find a control board that is still in production. Can anyone help? Model number is RBD305PDB12 ser # CPO403303.

Carolinian Posted: Wednesday, October 29, 2014 4:14:49 AM(UTC)
A final update on my journey to fix the oven. I also tested the fuse with a multimeter and the resistance was fine (so that was not the problem). Ordered the control board assembly (board + black plastic cover) from Appliance Parts Pros, for about $260 and replaced it in the oven. After plugging in the connectors, I turned on the switch at the circuit breaker and then switched on the oven, it worked like a charm. Also tested it for a month to see how it performs and we are back to normal now.

I had asked good repair places and they quoted over $500 to fix it. APP shipped quickly and delivered the board in a couple of days and I was very pleased with them. Thank you, APP
Carolinian Posted: Tuesday, September 30, 2014 8:33:21 AM(UTC)
Just answering my own question. It was pretty hard to yank off the wires from the relay but all it needed was a good hard tug. As for the other 2 harnesses, that also would not pull out easily, I had to push it up by placing a screwdriver under the black connector and then pull it out. Those were really hard to figure out for me. Hope this helps someone :)