Appliance Repair Forum

Appliance Repair Forum (http://forum.appliancepartspros.com/)
-   Washer Repair (http://forum.appliancepartspros.com/washer-repair/)
-   -   GE Washer does not agitate or spin (http://forum.appliancepartspros.com/washer-repair/76774-ge-washer-does-not-agitate-spin.html)

Tammy2006 02-07-2010 08:40 PM

GE Washer does not agitate or spin
 
I have a GE Profile Washer Model WPRE6100G0WT. The washer get the power/display but neither agitates nor spins however it drains fine (separate motor). I have done some troubleshoot and below are the tests & results:

Lid safety switch (magnet type) was tested and OK.
Fuse on neutral line was tested and fine
Field service mode was set and tested with no error on the result
120V power are present at the inverter (pin 5 & 6 of C2 connector)
I have tried reset the inverter (Open/Close lid 5 time in 10 seconds, 6 times in 12 seconds, 7 times …) but they did not help
I don’t see any blink on the converter board

Does anyone have any idea of what may be wrong? Does the motor went bad? I can buy the motor for about $160 but I am afraid it won’t fix the problem (some articles say the bad mode shifter will cause no blink on the inverter)
This unit is less than 3 years old, does anyone by chance know the warranty length for this model (GE Profile Washer Model WPRE6100G0WT)

Thank you

sidfink43 02-09-2010 06:12 PM

A bad mode shifter should give you blinking, I mean, that's what the blinking is for, but with these GE machines anything can be possible.

I suggest you try and determine if the motor is getting power, if so, then it is likely, but not certainly the problem given you other tests.

Here is a service manual in case you do not have one.

Google Docs

Tammy2006 02-09-2010 07:34 PM

sidfink43,

Thanks for your response especially for the service manual which has the info to test the controller, inverter (page 39).
I did check the power at the inverter and it had the power (120V at C2 Pin 5&6 and Neutral at C2 pin 3) . I also agree with you if the mode shifter went bad the inverter should blink 4 times.
I think my washer has a bad inverter, I have ordered a new inverter and it's on its way. I will keep the board updated.

Thanks,

Tammy2006

sidfink43 02-10-2010 06:01 AM

Thanks, let us know how it turns out because the more info we can get on this model the better we can all help folks.

Tammy2006 02-13-2010 11:27 AM

The motor/inveter was the problem. Replaced it and it works like a charm. Thanks for all the input.

sidfink43 02-13-2010 12:27 PM

Great, nice going on fixing it and thanks for the update.

Mudracer 03-30-2011 07:17 PM

Washer Inverter/Motor
 
How much did hte inverter/Motor cost you and where did you get it from? Do you happen to remember hte part# for it? I have the same issue on my machine and im contemplating on purchasing a new one.

Any help is appreciated!

Thanks

sidfink43 03-31-2011 05:02 AM

Mudracer

You can call APP, this site here, and give them your model number and they can quote a price for you. If the motor/inverter does not fix your problem you can return it, see the returns policy for details and conditions.

Good luck.

Mudracer 03-31-2011 07:49 PM

Thanks. I will call them up.

I tested the fuse wire and im not getting continuity. None of the LEDs turn on either. I hope its just a bad fuse I just ordered it.

sidfink43 04-01-2011 05:44 AM

That is very likely, hope that will fix things.


All times are GMT -7. The time now is 08:49 PM.

Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17