Appliance Repair Forum

Appliance Repair Forum (http://forum.appliancepartspros.com/)
-   Washer Repair (http://forum.appliancepartspros.com/washer-repair/)
-   -   GTWN5050M0WS - Service mode does nothing, fill light blinking (http://forum.appliancepartspros.com/washer-repair/573192-gtwn5050m0ws-service-mode-does-nothing-fill-light-blinking.html)

Sienile 02-17-2018 11:39 AM

GTWN5050M0WS - Service mode does nothing, fill light blinking
 
A few weeks back my washer stopped working. It would flash the fill light and beep twice occasionally (other forum user said 20 seconds between pairs of beeps, mine seems slightly longer). After replacing the main control board (the one with the knobs) it did the same thing. I did manage to get it to work for a single cycle while the washer was partially disassembled, but upon reassembly it went back to the same state.

I've tested continuity in the harness, lid switch, and pressure sensor. I have communication on the DC lines: Blue-Red constant 12.3V, Blue-Yellow fluctuating 12V (using a DMM, so can't tell what the pulse rate/range is). AC voltages are good.

Checked ohms on:
  • motor (.5 ohms) <--- seems suspicious
  • mode shifter (68 ohms)
  • water valves (1.03K ohms)
  • thermistor (55K ohms @ 75F)
  • drain pump (14 ohms)

With the original control board I had no motor codes. Since replacing it I've gotten a code 10 while messing around with it, but it's usually because I interrupted a signal while live testing circuits. I'm fairly certain I need the motor-inverter assembly, but given the price (over half the purchase price of the entire washer) I want to be absolutely sure.

The reason why I'm at all doubting this is: When I enter service mode, I'm pretty sure after the model and 3 error positions that the remaining positions are supposed to operate various functions according to the chart on the data sheet... but nothing happens other than the lights come on in the positions listed on the sheet. (I actually used this to double check my pressure switch by blowing into the tube during the function checks to make the last light come on.) Is this the correct function of service mode or is it actually supposed to run the listed functions like I'm thinking? Does this indicate a defective control board or another issue?

Forgot to mention, this is the newer version with the red light and no in-line fuse.

Sienile 02-18-2018 09:15 AM

Well, this is strange. I had the top and front panel off and the agitator removed from my previous testing. I plugged up the washer and then noticed the I had left some connectors off (3 wire plug on control board going to pressure switch and thermistor, inlet valves, mode shifter, motor coil, and drain pump). I plugged in the 3 wire plug and inlet valves, then went to plug in the drain pump. The connector arched as I plugged it in and the drain pump started to run... forever.

I can't remember if I unplugged the washer before reconnecting the mode shifter and coil, but I think I did since there's a lot of AC connections that I definitely didn't want to touch live. The washer didn't stop the drain pump until the washer was unplugged. On plugging it back up my fill light was no longer flashing, but the motor was blinking a code 10.

I unplugged the washer, shorted the plug against the case, then plugged it back in and did the lid switch reset. The washer started to and is currently working with the panels and agitator out. (It's a good time to clean the bottom of the washing tub since I'm a mechanic and there's a lot of grease sludge hiding under the agitator. Just hold a brush to it while it spins. :P)

Sienile 03-10-2018 10:46 AM

Well, this is even more strange. The washer had been working flawlessly since doing the things in my last post (3 weeks ago). Then it started doing the exact same mess: Blinking fill light, no functions working. So I open the case up and start testing. All voltages and resistances matched my previous measurements.

On a hunch, I try on purpose what I did accidentally before. I left connectors off for the 3 wire plug on control board going to pressure switch and thermistor, inlet valves, mode shifter, motor coil, and drain pump. Then I plugged in the 3 wire plug and inlet valves, then went to plug in the drain pump. Same result as last time: the drain pump started to run forever.

This time I know I unplugged the washer before reconnecting the connectors on the inverter board. No code 10 to clear this time... Perhaps last time I was ballsy enough to connect them before while live.

So since this works as a reset, if it needs it again I will try only removing the connectors from the inverter board (one at a time) to see if I can narrow down the issue. I have a feeling the root cause is either the mode shifter or the motor coil itself, and I'm leaning towards the motor coil since I found what seems like glue on the coil wires near the connector end... I don't remember that being there last time and I'm wondering if it might be some sort of clear coat from the wire insulation. My wife has a bad habit of overloading the washer and it wouldn't surprise me if the coil is heating up enough to start to melt things.

Sienile 03-17-2018 07:14 PM

Well, it made it just a week this time. This time it's behaving a bit different. My improvised reset procedure did not work. I can get it to do the infinite drain cycle by disconnecting the thermistor/pressure switch connector, but nothing will make it stop. With it connected it just does the blinking fill light error.

On the up side, I am getting a fill error in service mode. At least it's finally recognizing the problem. Service mode functional tests still do nothing. The inverter board will sometimes flash the code 10, but not every time. Is it possible that the barely a month old control panel has gone out?

Sienile 03-18-2018 11:40 AM

Got it to engage. I blew into the pressure sensor hose (first click) while trying to start an "Extra Heavy" fill cycle and the drain pump started running. I stopped the cycle and reconnected the hose. Then I started a "Medium" cycle and it began to fill. I had already detached the lid magnet and had it directly on the switch, so I was able to load the washer without stopping the cycle.

We'll see how it goes, however this is making no sense to me. The pressure switch is functioning correctly with proper continuity at all stages. I see no reason why anything I've done to make this washer work should have worked (other than replacing the control board that had a charred diode).


All times are GMT -7. The time now is 01:37 AM.

Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17