Appliance Repair Forum

Appliance Repair Forum (
-   Washer Repair (
-   -   FH error code on Duet front load washer (

jimhokie 10-15-2013 04:17 PM

FH error code on Duet front load washer
When my wife started a cycle, it initially added water, but after about 10 minutes, the cycle had stopped and it was displaying the FH error code (apparently after the second time in the cycle when it adds water). Subsequent attempts to run a cycle did not add ANY water, and would display the FH code within a minute or so.

I verified the water supply valves are on, the inlet screens are clean (new inlet valve!), and the pump strainer/filter is clean.

I ran the diagnostic test, and at Step C:01 (tests flowmeter and cold water inlet valve), the test displayed code FH. I restarted the test and skipped over this step so the rest of the tests could be run. It next stopped at C:03 (tests hot water inlet valve)--FH code. I restarted and skipped past C:03, and it stopped at C:05 (test heater if present (not on mine), and if there is not enough water in the tub, it adds water)--FH code. I restarted and skipped past C:05 and it completed the remainder of the diagnostic tests with no error messages. Since the only steps flagged were those where water was supposed to be added, it sounds like a bad water inlet valve, right? No--I replaced that and get the exact same symptoms.

Since I had similar symptoms about 2 months ago, that ended up being a bad drain pump motor, I tested the motor resistance (OK) and that it was getting voltage (OK), and could see that it tries to pump a small amount of residual water in the drain line, so it is turning. Don't think it's the drain pump.

I then tested the voltage going to both the hot and cold water inlet valve solenoids, and neither is getting voltage when they should be opened. I unplugged and replugged the wiring harness into the control unit to ensure a good connection. I notice that when starting a cycle, the drain pump is running continuously until the error code stops the cycle. The manual description of the pressure switch says "If an overfill condition is detected by the pressure switch, the CCU will turn on the drain pump and attempt to stop filling." So, could the pressure switch be falsely detecting an overfill, and therefore running both the drain pump and preventing water from coming in? I had dismissed the pressure switch because that is only noted as a possible problem for code FH if there is water in the unit, but it is not adding any water, so the pressure switch is not indicated in that case.

Could the pressure switch fail like this--falsely detecting an overfill rather than just not detecting any water?

Any other thoughts?

Thanks in advance for any wife would be extremely grateful!


jimhokie 10-15-2013 06:55 PM

Oops, my correct model number is GHW9150P.

jimhokie 10-16-2013 06:52 PM

More Info:

I disconnected the pressure switch tubing and blew through it. It is not clogged. I attempted a cycle with the tubing disconnected...same error code. When I blow into the pressure switch, I hear one click with light pressure and a second click with a little more pressure, and it clicks similarly as I release the pressure, so it sounds like the low level and overflow levels are activating and deactivating properly. I do get continuity across the terminals that should be connected when the tank is empty (per the manual), so the pressure switch seems OK.

Does anyone know how to check the flowmeter, which is one of the things recommended to check for the FH error code? Neither the manual nor tech sheet say how to test this. I tried to ensure it was properly connected, but when I pulled the connector plug, a little circuit board came out with some sort of sensor on it. I presume this sensor detects revolutions of the internal paddle wheel as a way to measure flowrate. How can this be tested other than replacing it?

I'm leaning toward the flowmeter being the problem by process of elimination, but still puzzled how this will prevent water from entering even at the beginning of the cycle before the CCU determines it is not measuring any water flow. I wonder if the unit does some kind of diagnostic at the beginning of a cycle before allowing any water to enter, that prevents the water valve from opening if it detects a fault in, say in the flowmeter, pressure switch, and/or the drain pump (I had similar symptoms a couple months ago when my drain pump motor crapped out). Or maybe it just remembers from the previous cycle if something isn't working right, and prevents any new water input after that.

I called Whirlpool customer support today hoping to talk to a tech person that could answer these types of questions, but they only have people that read the troubleshooting tips straight out of the manual, so no further insight there into the logic of the control system.

Well, if no one has any info/experience to share, hopefully my info above will help someone in the future to diagnose the apparently very common FH error code. If/when I get it fixed, I'll share what worked.

HumboldtRepairMan 10-17-2013 05:35 PM

What brand and type of soap are you using?

ckphoto 10-18-2013 12:11 PM

did you ever get if fixed? if so what was the answer?

jimhokie 10-18-2013 01:44 PM

Tide HE. Can the type of soap used somehow cause the FH error?

jimhokie 10-18-2013 01:45 PM

Ckphoto: Not yet...the flowmeter wasn't it. Trying the pressure switch next. Are you having the same problem?

ckphoto 10-18-2013 02:02 PM

Yes, replaced pressure switch, no help, but blew thru flowmeter, and took off inlet valve, confirmed clean, re-assembled and ran 1 wash no problem...odd.

jimhokie 10-18-2013 06:20 PM

Maybe you had a bad connection and disconnecting/reconnecting fixed it. Or, a couple months ago, I had the exact same symptoms, which turned out to be a bad drain pump motor, but initially, it was intermittent. Sometimes the motor would hang up, then work again. When you first start a cycle, the drain pump kicks on, so if it doesn't work at that point, or at any other point in the cycle where the drain pump kicks on, it will give the FH error. When I first checked the motor resistance it was OK, and after several more failed cycles where it would FH at various points in the cycle, the motor resistance showed it was bad. Replaced the motor and it worked after that, until this new problem. (Most places only have the combined pump housing and motor for $150. I found one place online that sold the motor separately for ~$50. I had to buy a new o-ring at a hardware store to go with it, but that did the trick.) Good luck not having a recurring problem!

jimhokie 10-22-2013 07:06 PM

Despite the self-diagnostic test not flagging the CCU, I finally replaced the CCU after a new pressure switch also did not fix it. The new CCU fixed it!!! My final theory that the reason the control wasn't sending voltage to the inlet valves to open was because of a CCU malfunction rather than some other control input to the computer (bad pressure switch, bad drain pump motor, bad flowmeter, etc.) preventing the control from signalling for water, turned out to be correct.

Lesson learned: Don't rule out the CCU just because the self-diagnostic test doesn't flag it.

Also, I learned how to test the flowmeter. The tech sheet inside the washer only says to blow into it and measure the resistance, but doesn't say what a working or bad unit resistance would be. Here's the deal: put the ohmeter probes on the two contacts while you blow through the flowmeter. A properly working flowmeter will read 0 before blowing in it and 3-4 ohms (or 30-40 or 300-400, not sure what setting I had the dial on). A few seconds after the rotor stops turning, the resistance drops back to zero. Both my original and replacement did the same thing, so I put the old one back in.

I hope this thread helps someone else with the FH error code.

All times are GMT -7. The time now is 01:15 AM.

Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17