Discuss

Maytag Bravos Washer

 in

Washer Repair

. "

My Maytag Bravos top load washer lid lock light is flashing and the washer will not turn on. I replaced

..."
 
 
Register | FAQ's | New Posts | Today's Posts | Extras
Appliance Repair Forum > Appliance Repair Help > Washer Repair » Maytag Bravos Washer

Post New Thread  Reply By reading any content on this site you agree to AppliancePartsPros.com, Inc. disclaimer and Terms of Use.
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 03-28-2013, 09:42 AM
Junior Member
 
Join Date: Mar 2013
Posts: 5
TreyWaltman is on a distinguished road
Default Maytag Bravos Washer
Brand: -brand-   Age: 1 - 5 years   

Appliance Parts from AppliancePartPros.com


My Maytag Bravos top load washer lid lock light is flashing and the washer will not turn on. I replaced the lid lock assembly and it still makes a noise when i try to start it and the lid lock light flashes. Please help!!

Reply With Quote
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
  #2 (permalink)  
Old 03-28-2013, 10:37 AM
Expert
APP Volunteer
 
Join Date: Oct 2012
Posts: 2,790
fairbank56 has a spectacular aura about
Default

What is the model number of your washer???

Eric
Reply With Quote
  #3 (permalink)  
Old 03-28-2013, 03:04 PM
Junior Member
 
Join Date: Mar 2013
Posts: 5
TreyWaltman is on a distinguished road
Default

Maytag Bravos

ecoconserve

it's MVWX600XW0
Reply With Quote
  #4 (permalink)  
Old 03-28-2013, 03:32 PM
Expert
APP Volunteer
 
Join Date: Oct 2012
Posts: 2,790
fairbank56 has a spectacular aura about
Default

This is a Whirlpool vertical modular washer design which has been very problematic. I would first tilt the machine back, remove the belt cover and check the belt and that the main pulley nut is tight. Then check and make sure all the connectors are tight at the motor, shift actuator, capacitor, and pump. You'll have to pull the pump cover back to get to the connector. Also check the connections at the control unit behind the control panel. There should be a manual inside the cabinet that will show how to get into service mode to check for errors and run diagnostic tests on things. The shift actuator is a high failure item and can cause the symptoms you are having. Lid locks, unlocks, locks again and then nothing but flashing lid lock LED. See this website for info on this washer design.

Eric
Reply With Quote
  #5 (permalink)  
Old 03-29-2013, 08:10 AM
Junior Member
 
Join Date: Mar 2013
Posts: 5
TreyWaltman is on a distinguished road
Default

Thanks Eric i may have bought a new lid lock switch and i didnt even need to.
Reply With Quote
  #6 (permalink)  
Old 03-29-2013, 03:33 PM
Junior Member
 
Join Date: Mar 2013
Posts: 5
TreyWaltman is on a distinguished road
Default

Eric,
How can i tell if the shift actuator is bad by looking at it?
Thanks!

Last edited by TreyWaltman : 03-29-2013 at 04:03 PM.
Reply With Quote
  #7 (permalink)  
Old 03-29-2013, 04:31 PM
Expert
APP Volunteer
 
Join Date: Oct 2012
Posts: 2,790
fairbank56 has a spectacular aura about
Default

You can't. You can do the diagnostic tests on it in service mode as per the service manual or you can test it with multimeter but it has been found that even when these tests show that the shifter is good, replacing it fixes the problem. Apparently, the rpm sensor fails in normal use but can test ok during static testing. The shifter is a very high failure item in these washers.

Eric
Reply With Quote
  #8 (permalink)  
Old 03-31-2013, 01:10 PM
Junior Member
 
Join Date: Mar 2013
Posts: 5
TreyWaltman is on a distinguished road
Default

Eric,
Thanks for your help I'm almost positive it's the shift actuator because the nose I hear is coming from it. It's like it tries to start but can't so I'm gonna replace it to see if it works.
Thanks!
Trey
Reply With Quote
  #9 (permalink)  
Old 08-12-2014, 06:10 AM
Junior Member
 
Join Date: Aug 2014
Posts: 1
Bnicoll84 is on a distinguished road
Default

I just had an issue on one of these. Turned out it was the wiring harness. Underneath the unit there is a roll of extra red wire that tends to get pinched due to the zip ties. That red wire runs from the capacitor to the motor. Hope this helps.
Reply With Quote
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
maytag bravos washer MIKIMAC1952 Washer Repair 1 03-27-2013 02:55 PM
Maytag Bravos Washer SamCraciun Washer Repair 0 09-19-2012 09:25 PM
maytag bravos washer 1beatlesfan Washer Repair 1 07-10-2012 03:57 PM
maytag bravos washer dengle Washer Repair 0 04-25-2012 05:13 AM
Maytag Bravos Washer donnadel123@bellsouth.net Washer Repair 1 08-11-2011 07:03 PM



All times are GMT -7. The time now is 01:06 PM.

The content on this web site is for informational purposes only and is not intended to replace an on-site diagnosis from a qualified appliance service technician. By reading any content on this site you agree to AppliancePartsPros.com , Inc. disclaimer and Terms of Use.
Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17