Appliance Repair Forum

Appliance Repair Forum (http://forum.appliancepartspros.com/)
-   Washer Repair (http://forum.appliancepartspros.com/washer-repair/)
-   -   Need Help with Kelvinator Washer (http://forum.appliancepartspros.com/washer-repair/34051-need-help-kelvinator-washer.html)

jemunger 05-19-2009 07:04 AM

Need Help with Kelvinator Washer
 
Hi all,

Kelvinator Washer - Out of the gate, the washer filled with water, then the trouble started. When we pull the switch to start the washer, the motor hums, then clicks off. After about 30 seconds something clicks again and the motor will react the same way. During that 30 second period - nothing happens (must be because of the timer). Anyway, the washer is 14 years old. I emptied the water by hand (and clothing). I took off the front cover, and checked belts, pulley's and etc. and all seem to be physically sound. I checked the belt tension and it is not super tight, but making good contact with the pullies/wheels. The motor/rotor is not running while the humming occurs (or at any time). I took the belt off just to get a better look at the motor/rotor. The rotor is not rotating when I turn on the washer with the belt off either. Any ideas? I am thinking the motor is bad...

jemunger 05-19-2009 07:20 AM

All, The Model number is MWX445MBW0

Gene 05-19-2009 04:41 PM

The motor has gone bad and unfortunately it has been discontinued by the manufacturer and is no longer available. Looks like it's time for a new washer.

Gene.


All times are GMT -7. The time now is 06:34 PM.

Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17