Appliance Repair Forum

Appliance Repair Forum (http://forum.appliancepartspros.com/)
-   Refrigerator & Freezer Repair (http://forum.appliancepartspros.com/refrigerator-freezer-repair/)
-   -   Freezer Not (http://forum.appliancepartspros.com/refrigerator-freezer-repair/484137-freezer-not.html)

Rockmeal 06-25-2012 07:53 PM

Freezer Not
 

Part 1: I have a 2003 GE PSH23NGPABB side by side. The control panel 3lb. onthe express thaw is lit and I cycle through the selections till it turns off. Iclose the door and open it again and the 3lb. is lit again. Whatís the deal?
Part 2: The freezerworks fine when itís cool out but as soon as the temp goes to 90 and above. Thecontrol panel reads 18 freezer and 35 fridge. I get high readings and thingsstart to thaw (Meat, ice cream, etc). Defroster is working, no ice buildup, changedall three thermistors ( evap, freezer, fresh food), the fans are working. Needhelp

Gene 06-26-2012 03:08 PM

1. Try to reset the control by: push and hold Freezer Warmer, Food Colder and Express Thaw buttons simultaneously. The thaw light should blink and go out. Unplug the refrigerator for 20 seconds.

2. Did you clean the condenser coils on the back of the fridge?

Gene.

Rockmeal 06-26-2012 06:35 PM

#1 I did what you said, pushed the buttons. The 5lb lite came on then the 3lb. blinked and both stayed on, the thaw fan came on and I unpluged it for 20 sec.. I pluged it back in and the express thaw was on for 4hrs.. I cycled through, it turned off. I closed the door and the light stayed off. It went down different but the results were the same.
thanks
#2 I clean them yearly but I got this late and will check tomorrow.

Rockmeal 07-02-2012 08:40 AM

Everthing worked fine on the testing, fans, dampners, communication (board to control), thermistors and reset. The temp is still high 20 and 44. I cleaned the coils, they weren't bad to begin with. Whats left?:(

Gene 07-02-2012 12:06 PM

Remove the rear panel inside the freezer and check how the evaporator coils are covered with frost. Post the results.

Gene.

Rockmeal 07-02-2012 05:09 PM

Like I said in the opening question the coils were lightly frosted. This time the bottom part of the coils were frosted. I replaced the thermista and the defrost sensor last summer. I did a defrost test and the heater came on and defrosted the coils. I reset it and put every thing back. I did all the tests again and they passed. I put it into a pre-chill mode which will return to normal on its own. What is pre-chill mode? and what do I do now???

Rockmeal 07-03-2012 01:18 PM

Well this is the next day and instead of cooling the temps went up to 37/60 outside temp is 85 deg. whats going on???

Gene 07-03-2012 04:32 PM

The warm temperature in the fresh food compartment caused by the warm temperature in the freezer. If the condenser and the evaporator fans are running as well as the compressor, and there is normal air flow within the freezer, then there is something wrong with the sealed system.

The pressure inside the sealed system as well as the compressor performance should be checked by a certified tech.

Gene.

Rockmeal 07-03-2012 04:38 PM

Any recommendations in my area, long island new York

Gene 07-03-2012 04:41 PM

You can try this website.

Gene.


All times are GMT -7. The time now is 12:20 PM.

Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17