Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Leonie  
#1 Posted : Monday, February 13, 2017 4:33:30 AM(UTC)
Leonie

Rank: Member

Groups: Registered
Joined: 2/13/2017(UTC)
Posts: 1

Hello everybody!

My Name is Leonoe, I am 24 years old and I come from nothern Germany.
I bought an used KitchenAid Heavy Duty on ********. When I connected it to the socket , it kicked the assurence. (I'm sorry, many new english words for me..)

after I replaced the part you can the on the Picture below, it does turn on but only one speed, so I can't regulate the speed also when I move the switch.
Also the Kitchenaid does make sounds when it's actually turned off but plugged into the socket...

Does anyone know what it could be? Maybe the switch?



I want to say sorry for my english, I am still learning :)


Best Regads :)

On the picture you can see the new one on the left and the old one at the right.
replaced the Part you can see on the picture, I don't know the english word in german it is called ''Funkstörsatz''.
Leonie attached the following image(s):
kondensator.jpg (38kb) downloaded 2 time(s).

You cannot view/download attachments. Try to login or register.
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.