Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
sammyc  
#1 Posted : Thursday, December 18, 2014 8:27:56 AM(UTC)
sammyc

Rank: Member

Groups: Registered
Joined: 4/1/2013(UTC)
Posts: 3

Recently I found that the refrigerator had started to warm up from setting. I switch it off for a day switch on and if worked perfectly for 2 days then it started to warm up again. I again switch it off and started it up. I could feel the compressor motor turning and it worked fine until controls caused it to malfunction again. Change the start up capacitor no change. Always work perfectly but the after about 6 hours you hear a click as if a relay is kicking in the for about 6 seconds but the compressors looses control and the temperature rises.
It is obvious that the compressor can cool the refrigerator but the start up after temperature has been achieve does not work. I read that if you hear this clicking sound the compressor is likely bad. however, cool down top and bottom works perfectly until the compressor starts give this clicking sound after about a 6 hours to a day of operation.

Any Ideas what may cause this.
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.