Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
AndreDW  
#1 Posted : Thursday, May 14, 2009 1:42:08 PM(UTC)
AndreDW

Rank: Member

Groups: Registered
Joined: 5/14/2009(UTC)
Posts: 3

I bought this range a little over a year ago. Recently, when using the oven at a temperature above 325 degrees the oven will reach the desired temp then cut off a few minutes later. When it cuts off, it beeps with two quick beeps, flashes "bake" continuously and the oven light goes out for a moment or two. I am unable to use the oven until the oven light starts working again.
We don't experience this every time we use the oven.
The control board has been replaced twice so I don't think it is the cause of the problem.
We don't experience this problem when the temperature is set at or below 325 degrees.

Thanks in advance
AndreDW
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Gene  
#2 Posted : Thursday, May 14, 2009 8:10:45 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

Originally Posted by: AndreDW Go to Quoted Post
...The control board has been replaced twice...


Hi Andrew,

Did it fix the problem, even temporary? Who replaced the control board?

Gene.
AndreDW  
#3 Posted : Friday, May 15, 2009 7:47:57 PM(UTC)
AndreDW

Rank: Member

Groups: Registered
Joined: 5/14/2009(UTC)
Posts: 3

Originally Posted by: Gene Go to Quoted Post
Hi Andrew,

Did it fix the problem, even temporary? Who replaced the control board?

Gene.


Each time the control board was replaced we experienced the problem the same day. Each time it was replaced by a repairman. The repairman thought the first replaced board was faulty and ordered the second one.

AndreDW
Gene  
#4 Posted : Friday, May 15, 2009 8:04:58 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

Such problem is very hard to diagnose. If the board has been replaced while the range was under the warranty and it did not solve the problem then you have to talk to the Maytag authorities. If they can not fix it then they should give you a new range. This is not an easy task and you have to be very hard with them.

Gene.
AndreDW  
#5 Posted : Friday, May 15, 2009 8:24:44 PM(UTC)
AndreDW

Rank: Member

Groups: Registered
Joined: 5/14/2009(UTC)
Posts: 3

Thanks Gene
Gene  
#6 Posted : Friday, May 15, 2009 8:27:44 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

You are welcome. Keep us posted.

Gene.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.