Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

10 Pages<12345>»
Options
Go to last post Go to first unread
2835AW  
#21 Posted : Wednesday, March 26, 2008 6:17:22 PM(UTC)
2835AW

Rank: Member

Groups: Registered
Joined: 3/24/2008(UTC)
Posts: 3

Original Oven And Broiler Would Not Light
Model #jgbc20gev3wh
No Prior Troubleshooting
Gene  
#22 Posted : Wednesday, March 26, 2008 6:24:15 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

The first thing I would do is check for 120V to the igniter while the oven thermostat calls for heat.

If there is no 120V, check the wires then bypass the thermostat and see if it works. If it does - replace the oven thermostat.

- The part number for the oven thermostat is AP2623073

Gene.
bobit  
#23 Posted : Saturday, June 28, 2008 1:53:28 PM(UTC)
bobit

Rank: Member

Groups: Registered
Joined: 6/28/2008(UTC)
Posts: 2

I am replacing the flat 3 3/4" igniter in my GE JGSP28 gas range. The one I bought locally does not have the matching snap connector. I forsee a problem because if I cut off the in-place connector half, there will not be enough wire sticking through the whole in the back of the oven to make a proper connection with the wire nuts.
Question: This is not a genuine replacement. They said it was a Kelvinator part. Is it possible that I could obtain a replacement that has the matching connector half? It would make life a lot easier.
Gene  
#24 Posted : Saturday, June 28, 2008 8:37:48 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

The part number for the GE oven igniter with the quick disconnect plug is AP3202322

Gene.
bobit  
#25 Posted : Sunday, June 29, 2008 8:57:00 PM(UTC)
bobit

Rank: Member

Groups: Registered
Joined: 6/28/2008(UTC)
Posts: 2

Originally Posted by: Gene Go to Quoted Post
The part number for the GE oven igniter with the quick disconnect plug is AP3202322

Gene.

The part number for the GE oven igniter with the quick disconnect plug is AP3202322

Gene, Thanks for the prompt reply to my email of 6-28-08. You posted a photo of a flat ignitor in your 9-27-07 reply #3 to lrg51. It looks exactly like the part I need to replace. I checked the details and found the p/n is Maytag AP205873. In your reply you gave me p/n AP3202322. Am I missing something? Are they the same parts with different p/n?

Also, I asked if the igniter would come with a connector halve to match the quick connector halve on my GE model JGSP28WEK2WW. Please advise.
Gene  
#26 Posted : Monday, June 30, 2008 1:40:56 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

The igniter with the part number AP3202322 made by GE. The igniter with the part number AP205873 made by Maytag. They look very similar but I'm not sure if their plugs are identical. I would recommend to use the igniter made by GE .

Gene.
ronlovell  
#27 Posted : Thursday, July 3, 2008 4:09:41 PM(UTC)
ronlovell

Rank: Member

Groups: Registered
Joined: 7/3/2008(UTC)
Posts: 1

I have 115 volts comming to the ignitor and gas valve. I replaced both the ignitor and gas valve as both were bad. After installing both new parts the oven came on and worked like it should. Then the next time I went to use it again it would not work. Still have correct power to both. Pretty expensive parts for one time use.:confused:

Kenmore gas range....Model 911.7199180...Ser.# 0F60407
Gene  
#28 Posted : Monday, July 7, 2008 3:14:31 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

ronlovell,

Please describe how did you measure voltage to these parts.

Did you check them for continuity?

Gene.
barryr2  
#29 Posted : Saturday, December 20, 2008 11:47:27 AM(UTC)
barryr2

Rank: Member

Groups: Registered
Joined: 12/20/2008(UTC)
Posts: 1

Hi,
I have the same problem with my GE XJ44, Model Number: JGBS23BEA2AD.
The Igniter (Glowbar) Will glow, but there is no gas flowing to the burner, and the oven will not work.
I read that most likely it is a faulty igneter.
Is it really bad, even if it glows? Or perhaps it is a bad valve?
How can I be certain what part needs to be replaced?
Do you know what are the propper P/N's for the Igniter and the valve?
Thanks,
Barry
Gene  
#30 Posted : Monday, December 22, 2008 11:19:16 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

Hi Barry,

Most likely the problem is a weak igniter.

You can learn how the oven igniter works from one of our previous posts: http://forum.appliancepartspros...1897-oven-wont-lite.html

If you want to be certain then you have to measure the current drawn by the igniter. It should be more than 3.2 amps.

- The part number for the oven igniter is AP2020569

Here are the break down diagrams for the GE range Model JGBS23BEA2AD

Gene.
Users browsing this topic
10 Pages<12345>»
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.