Discuss

lady Kenmore oven & broiler prob

 in

Oven Repair (including Ranges and Cooktops)

. "

I have a gas range lady Kenmore, I believe to be more than 10 yrs old. when i set the

..."
 
 
Register | FAQ's | New Posts | Today's Posts | Extras
Appliance Repair Forum > Appliance Repair Help > Oven Repair (including Ranges and Cooktops) » lady Kenmore oven & broiler prob

Post New Thread  Reply By reading any content on this site you agree to AppliancePartsPros.com, Inc. disclaimer and Terms of Use.
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 01-16-2014, 11:29 PM
Junior Member
 
Join Date: Jan 2014
Posts: 2
jag_32834 is on a distinguished road
Default lady Kenmore oven & broiler prob
Brand: Kenmore   Age: More than 10 years   

Appliance Parts from AppliancePartPros.com


I have a gas range lady Kenmore, I believe to be more than 10 yrs old. when i set the temp for the oven or the broiler I get a "on" code on the display and it shuts off the operation within a minute. I recently swamped the relays and terminals on the control board but that didn't fix it. any ideals on what may be the issue/s? the top burners work fine and there is no glowing on any of the elements.

Reply With Quote
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
  #2 (permalink)  
Old 01-19-2014, 08:23 PM
Junior Member
 
Join Date: Jan 2014
Posts: 2
jag_32834 is on a distinguished road
Default

a little update. I tried the oven again and there was power surge causing one of the house breakers to shut off. where would the fuse be located?
Reply With Quote
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Lady Kenmore twladykenmore Washer Repair 8 04-12-2013 10:21 PM
Lady Kenmore washer won't go through cycles MamaDancer Washer Repair 1 01-29-2012 10:40 AM
lady kenmore dryer rick perez Dryer Repair 2 02-02-2011 05:47 AM
gas oven/broiler prob: regulator solenoid or DSI board? grovest1910 Oven Repair (including Ranges and Cooktops) 9 02-04-2010 12:19 PM
Dishwasher-lady Kenmore www.sfocommuterflyer Dishwasher Repair 1 11-12-2008 06:38 PM



All times are GMT -7. The time now is 03:05 PM.

The content on this web site is for informational purposes only and is not intended to replace an on-site diagnosis from a qualified appliance service technician. By reading any content on this site you agree to AppliancePartsPros.com , Inc. disclaimer and Terms of Use.
Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17