Appliance Repair Forum

Appliance Repair Forum (http://forum.appliancepartspros.com/)
-   Oven Repair (including Ranges and Cooktops) (http://forum.appliancepartspros.com/oven-repair-including-ranges-cooktops/)
-   -   Whirlpool not heating at all (http://forum.appliancepartspros.com/oven-repair-including-ranges-cooktops/299611-whirlpool-not-heating-all.html)

tswanny50 09-11-2011 05:32 AM

Whirlpool not heating at all
 
The control panel on my whirlpool smooth top stove works perfectly, but the burners and the oven do not heat. Any ideas?

denman 09-12-2011 05:18 AM

Here are your parts
Replacement parts for RF378LXKQ models | AppliancePartsPros.com

Since the oven elements and stove top elements run off of 240 volts I would check that first. The control board and the oven light use half the line, 120 volts.

Try flipping the breaker off/on slowly a couple times.
Sometimes you can loose half the line without actually tripping the breaker.
If this does nothing, check the voltage at the plug
L1 to L2 should be 240 volts
L1 to Neutral and L2 to Neutral, both should be 120 volts.
If OK
Unplug the unit and check the wires at the terminal strip in the machine to make sure none are loose or burned out
If OK
Check the power at the terminal strip.
Do this with the heater off and on.
Be careful as 240 volts is lethal !!!


All times are GMT -7. The time now is 11:31 AM.

Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17