Appliance Repair Forum

Appliance Repair Forum (http://forum.appliancepartspros.com/)
-   Oven Repair (including Ranges and Cooktops) (http://forum.appliancepartspros.com/oven-repair-including-ranges-cooktops/)
-   -   Roper Electric Range - All Elements Not Heating (http://forum.appliancepartspros.com/oven-repair-including-ranges-cooktops/147984-roper-electric-range-all-elements-not-heating.html)

jables 11-30-2010 09:02 PM

Roper Electric Range - All Elements Not Heating
 
Just moved in to a new place and when I tried to use the stove, nothing heated but I heard a faint sizzle coming from the back. I pulled the range out away from the wall, turned it on again to see if I could hear better where it was coming from when suddenly I got a sizzle, pop and flash. I turned off the power to the range, pulled it out further and found that the metal conduit around the main wiring had cut through one of the hot wires and the ground, frying the hot wire. I spliced the wire, re-wrapped and connected everything back up. I have power (no sizzling or popping this time) but none of the elements even try to get warm. I do, however, get a constant clicking coming from the electronic control switch attached to the oven control knob whenever I try to turn the oven on, the following part:

Part Details - WHIRLPOOL SWTCH-OVEN, part number: AP3885365

I have thoroughly checked all wires and components on the range itself and nothing appears burnt or disfigured in any way. Everything seems fine. Looking for some possible other troubleshooting tips or simply a confirmation that this switch is bad. Lucky for me, it seems to be the single most expensive part on this thing.

Thanks in advance for any input,

J.

denman 12-01-2010 03:30 AM

Since none of the elements heat you still have a power problem.

The stove top and oven controls are different so I doubt that the oven switch will fix your problem.

You have to check that the unit is getting 240 volts.
Try flipping the breaker off/on slowly a couple times, sometimes you can loose half the line without actually tripping the breaker.
If this does nothing, check the voltage at the plug.
Yours sounded like it was hard wired so you may have to check it at the terminal strip only.
L1 to L2 should be 240 volts
L1 to Neutral and L2 to Neutral, both should be 120 volts.
If OK
Unplug the unit and check the wires at the terminal strip in the machine to make sure none are loose or burned out
If OK
Check the power at the terminal strip.
Be careful as 240 volts is lethal !!!

If you do not have electrical experience it may be time to call in a pro.

jables 12-01-2010 08:40 AM

Denman, thanks for the speedy response:) I have a family member with the necessary equipment to test that for me, I'll just have to wait a few days to get that done. I'll post back with my findings.

J.

jables 12-01-2010 07:07 PM

So it is...
 
The range is wired through a fuse box actually and as I was thinking about it, it occurred to me that maybe I should test the fuses. I never had to deal with this type of setup, which uses cartridge fuses. I had assumed that if one went bad, something would be visible to indicate that is was. However, after I got home tonight I tested both with the meter and one is reading open. Since this is a duplex I just grabbed the other tenant's fuse plug and tried that in my box and I'll be damned if the thing doesn't work like a charm. A simple fuse and I'm back in business :)

Thanks again for the fast response denman. I'll definitely be keeping tabs on this forum for my appliance needs.

J.

denman 12-02-2010 01:53 AM

You are welcome

And thanks for getting back to us. Now when others search for a similar problem they will see what actually worked instead of just suggestions about what could be the cause.


All times are GMT -7. The time now is 11:35 AM.

Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17