Register | FAQ's | New Posts | Today's Posts | Extras
Appliance Repair Forum > View Profile » krissyjo48183

View Profile: krissyjo48183
krissyjo48183 is on a distinguished road
krissyjo48183 krissyjo48183 is offline
Junior Member
 
Last Activity: 02-27-2010 08:43 AM 

Kenmore 500 disposer runs but blades not moving - Kenmore 500 disposer runs but blades not moving
Hello,

I have a Kenmore 500 Disposer 175.66554. I was running it the other day and the motor runs but the blades in the sink don't turn.

Is there a jam nut I can tighten or is it just time to...
Disposer turns on but blades don't turn - Kenmore 500 disposer runs but blades not moving
Hello,

I have a Kenmore 500 Disposer 175.66554. I was running it the other day and the motor runs but the blades in the sink don't turn.

Is there a jam nut I can tighten or is it just time to...
Forum Info Contact Info
Join Date: 02-27-2010
Posts
Total Posts: 2 (0.00 posts per day)
Last Post:
Disposer turns on but blades don't turn
02-27-2010 08:40 AM
Find all posts by krissyjo48183
Find all threads started by krissyjo48183
Referrals: 0
krissyjo48183 has no contact information.
Additional Information Group Memberships
N/A
krissyjo48183 is not a member of any public groups


All times are GMT -7. The time now is 08:33 AM.

The content on this web site is for informational purposes only and is not intended to replace an on-site diagnosis from a qualified appliance service technician. By reading any content on this site you agree to AppliancePartsPros.com , Inc. disclaimer and Terms of Use.
Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17