Register | FAQ's | New Posts | Today's Posts | Extras
Appliance Repair Forum > View Profile » Joe Mance

View Profile: Joe Mance
Joe Mance is on a distinguished road
Joe Mance Joe Mance is offline
Junior Member
 
Last Activity: 06-16-2018 06:31 AM 

Both heating elements do not heat - Both heating elements do not heat
Oven heated to normal temperature, after 20 minutes both elements lost temperature. Now neither element will heat. Control panel shows electricity is still on and both elements should be heating.
Temperature drops after 20 minutes - Temperature drops after 20 minutes
Oven heats to normal bake temperature. After approximately 20 minutes the heating elements turn off and the oven temperature drops. Fault code f1. Replaced temperature sensor did NOT solve problem.
Forum Info Contact Info
Join Date: 06-13-2018
Posts
Total Posts: 2 (0.02 posts per day)
Last Post:
Temperature drops after 20 minutes
06-13-2018 04:13 PM
Find all posts by Joe Mance
Find all threads started by Joe Mance
Referrals: 0
Joe Mance has no contact information.
Additional Information Group Memberships
N/A
Joe Mance is not a member of any public groups


All times are GMT -7. The time now is 04:42 AM.

The content on this web site is for informational purposes only and is not intended to replace an on-site diagnosis from a qualified appliance service technician. By reading any content on this site you agree to AppliancePartsPros.com , Inc. disclaimer and Terms of Use.
Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17