Appliance Repair Forum

Appliance Repair Forum (
-   Dryer Repair (
-   -   GE Prodigy dryer not heatijg (

ZachBoyer 07-04-2017 09:41 AM

GE Prodigy dryer not heatijg
My GE prodigy dryer has stopped heating. I have pulled it apart and checked heating elements and thermostats for continuity and everything is checking out ok I believe.

The heating elements are reading 20.0 ohms wiring diagram calls for 19.2 ohms

There were 3 thermostats on the drum. 2 - 2wire and 1 4wire. The 2 wire ones had continuity between the terminals, the 4 wire one had continuity between the outside terminals with all wires removed. The wiring diagram calls these safety left, control inlet, and thermo hi-limit.

I also checked 1 thermostat (4wire) on the exhaust by the fan on the motor, removed all wires and tested the outside terminals for continuity. Checks ok. The wiring diagram calls this one drum outlet.

I vacuumed out all of the lint in the bottom of the tray (there wasn't much) and on the motor then blew the motor out with compressed air and vacuumed up the mess.

Tested the dryer and still no heat. What else do I need to check? I have heard there is a switch on the motor that activates the elements when the motor is up to speed, how do I test this?

I guess the last thing to do would be to test the timers, how should I go about this?


PNWDrew 07-06-2017 10:47 PM

There should be a wiring diagram inside, it'll tell you which contacts in the timer should be closed when the timer is asking for heat. These will be closed whether or not the machine has power as long as it is in a position where heat is required (timed dry for instance) so look at the diagram and see if they are closed. They'll have a letter designation to ID them one the timer.

But first verify that the machine is getting 240v at the terminal block and that the hidden fuse (if there is one present at the terminal lock is not open) Flip your breaker several times if you are not seeing 240 at the wall / or terminal block. It sounds basic but it's gotten all of us a few times in our work.

ZachBoyer 07-09-2017 02:16 PM

1 Attachment(s)
I was doing my testing yesterday and the dryer heated in the medium heat setting. So today I do a load of laundry and again no heat.

I do have 240 on the meter, the timer/switch test as the diagram indicates. I tested both the Timer and heat selector switch.

I decided to go through and retest all of the thermostats and coils.

Safety Left - 0.4 ohms

Control Inlet - Outside terminals / 0.4 ohms
Inside terminals / 8.97k ohms

Hi-Limit Right - 0.4 ohms

Drum Outlet - Outside terminals / 0.4 ohms
Inside terminals / 8.91k ohms

Heater Coils - Inner / 19.8 ohms
Outer / 19.9 ohms

I have also attached a photo of the wiring diagram incase it helps any.

PNWDrew 07-09-2017 10:19 PM

Since you have heating at times we can rule out all safeties/thermos and the elements. None of them would be likely to have an intermittent issue other than a loose or burnt connector.

So that leaves the timer as the most likely issue. I'd definitely like to examine the prongs of the plug for evidence of arcing, same with the cord connections at the terminal block, either of which could cause intermittent issues. If no burns or pitting on those parts I'd say its internal to the timer. I may be wrong as diagnosis online is not easy on odd issues but you've got to start somewhere.

ZachBoyer 07-21-2017 03:02 PM

Hey Drew,

The intermittent heating may be an overstatement. It just heated once after it stopped heating, ironically when I was double checking connections and meter readings...

Anyways. I replaced bother the main timer and the fabric care heat selector switch. Still no heat.

I double checked for loose connections and evidence of arcing. No such luck of finding anything.

Where do we go next? Ive heard there is a speed switch within the motor or attached to the motor that may activate the elements, whats your thoughts.

I did run the dryer without the drum to attempt to see if the speed switch (if one exists) would let the heating elements come on. Figured if it was having an issue getting up to speed the removal of the drag of the drum may let it work. No Luck

I know its hard to diagnose over the internet but trying pretty hard, also dont want to just replace part by part if I dont have too.....

What do we crack the whip at next?


PNWDrew 07-21-2017 10:53 PM

There is a centrifugal switch on the motor that provides L2 120v to the elements. On that pic above trace L2 to the motor switch. That's it.
When the motor spins up a pair of spring loaded weights on the inner shaft spread out and push an arm to close the circuit. If one of those springs is off or broken that would cause it. You can slide the plastic color attached to the the weights to simulate spinning but moving the switch arm is easier. The arm itself hangs out of the back of the terminal block on most motors I've seen. You can manually move it and see if that circuit closes, creating continuity or very low resistance through the switch. It looks like it'll be black to purple on the motor terminal block. That brown plastic on the motor is pretty fragile so be gentle on it.
It is a possibility. Samsung had a batch of motors recently with bad centrifugal switches and the first few I saw really baffled me.
When you look closely all that will make more sense. I'll see if I can find a good pic of that set up if its action isn't apparent when you look at it. The weights are usually silver and the springs small and attached to each weight. Its worth checking since looking is free. You'll be a GE dryer expert soon.

ZachBoyer 07-23-2017 11:01 AM

3 Attachment(s)
Well looks like I found the problem. The L2 wire caused some chaos on the motor switch. It looks like the terminal was loose and may of starting arcing creating quite a bit of heat. Maybe it had rattled off of its post and rested against the post for my intermittent heat, and that's when it really heated the switch up.

I repaired the wire and put a new end and connected to the motor switch hoping it would work but no such luck, so i'm guessing something has melted within the switch. The brown parts of the switch do move with the clutch but I get no continuity anywhere so i guess I just need to get a new motor switch?

Ive looked at some breakdowns but cant seem to get detailed enough for a part number, do you have any idea of the part number.

I attached some pictures of the carnage.

PNWDrew 07-23-2017 03:40 PM

Well I'd say you found the problem.
We usually replace whole motor so I've never tried to find just the switch.

You might try using manufacturer data on the motor to look for parts or see if there's a local elec motor repair shop near you and get lucky, I doubt GE made it as the same brown switch is on most motors I've seen.
You'd need to cut that overheated and corroded wiring back to a good spot and crimp new terminals on or you'll be doing it again soon.
You may find a used appliance shop nearby with a boneyard that might have something too.

ZachBoyer 07-23-2017 04:03 PM

I bit the bullet and ordered a used one off of amazon for $45

I did cut it all back and splice in a new comnector.

I was about to fix the switch, but I lost a spring into the great abyss (go figure) on my last check attempt before sealing it back up. I was able to hot wire it and it worked so if it doesn't work with a new motor I will be blown away.

Hopefully this thread will help somebody else, I'm pretty sure we went through everything that could possibly go wrong with a dryer haha.

Really appreciate your help Drew. Unless it is a puzzle. Take it easy.

ZachBoyer 07-25-2017 02:44 PM

5 Attachment(s)
Nothing can be easy.

So I got the new motor in but the motor switch is different so I dont want to hook it up the wrong way. The instructions didnt give any details on the posts on the switch. It only said that the ground had to be moved to the shell.

Atleast the old switch had numbers on it, this one does not!

I have attached pictures of the new switch and the old switch pattern.

All times are GMT -7. The time now is 08:47 PM.

Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17