Appliance Repair Forum

Appliance Repair Forum (http://forum.appliancepartspros.com/)
-   Dryer Repair (http://forum.appliancepartspros.com/dryer-repair/)
-   -   Frigidaire Dryer Has No Heat (http://forum.appliancepartspros.com/dryer-repair/470449-frigidaire-dryer-has-no-heat.html)

moody9207 04-22-2012 07:18 PM

Frigidaire Dryer Has No Heat
 
Our Frigidaire dryer doesn't put out any heat, otherwise it is working okay. I've pulled it completely apart and removed the drum to check continuity on the heating element, the thermal limiter and the safety thermostat. All showed conductivity. The heating element measured 11.8 ohms, and both the thermal limiter and the safety thermostat measured 0.3 ohms. Are these readings okay? What else can I check?

moody9207 04-24-2012 11:22 AM

Looking at another parts display, I see that this dryer also has a cycling thermostat buried near the motor/blower assembly. I plan to check that for continuity tonight as long as I can get to it. How difficult will it be to put my probes on this part? If it is defective, how difficult is it to replace?

Simon / APP Team 04-24-2012 01:02 PM

Hi.

First thing you should have done - check if there 230VAC coming to the dryer.
The motor runs of 120VAC. Check the input at the terminal block at the rear of the dryer.
When you are checking the continuity do you remove one lid off?

Thank you. Post the results.

Simon.

moody9207 04-24-2012 07:42 PM

Thanks for responding. The dryer is actually from my daughter's house and I moved it over to my garage so I could take it apart without worry that my 2 year old grandson would get curious. I have no 220V in my garage so I cannot check the voltage input to the dryer.

I did measure the continuity of the cycling thermostat and found the wide terminals ok but the narrow terminals were not. I strongly suspect this thermostat is the problem and plan to check if my local appliance store has the part. If not, I will order online.

I checked continuity on all parts by removing both connections and putting the probes directly on the contacts. I did the same for the cycling thermostat, checking the wide terminals 1st and the narrow ones 2nd.

Simon / APP Team 04-25-2012 10:41 AM

Hi.
Good luck, but before going through all the hassle check the outlet for 230v.

Simon.

moody9207 04-28-2012 09:05 PM

I checked the outlet and it delivers 240V. I checked continuity of the power cord by touching one probe to one of the three posts and then touching one of the inputs on the terminal block. Only one input showed continuity and the other two did not. I checked the other posts the same way and in the end, all three show continuity to the respective input on the terminal block, so I believe the power cord is okay.

I also checked continuity on the terminal block for L1, N and L2. I checked these in the same way as above, measuring between the posts on the power cord and L1, N or L2. For all three contacts (L1, N, L2) I could find a post that gave 0 ohms resistance. This is the same post that gave 0 ohms resistance when measured across the imputs.

However, I'm concerned because I did purchase a new cycling thermostat and checked it for continuity the same way I did the old one - with the same result. I get a reading between the wide posts but not for the narrow posts. I would have expected to see resistance between both of the post sets.

Before I reassemble the dryer and take it to my daughter's house to see if now works, what else can I check?

Gene 05-01-2012 01:11 PM

Just to add my 2 cents...

Any further troubleshooting should be done with the dryer connected to the power source of 240 VAC. If you don't feel comfortable to do such tests, it's better to hire a pro to do it for you. Otherwise let us know when you will be ready.

Gene.
P.S. The cycling thermostat in such situation considered to be good while there is continuity across the large terminals.

moody9207 05-29-2012 06:17 AM

Well hello everyone, I finally put the dryer back into my daughter's house and verified that there is 230V coming into the terminal block. But after turning the unit on, there is still no heat. What are my next steps? I'm getting very frustrated.

Simon / APP Team 05-29-2012 10:05 AM

Hi.

Do you have the wiring diagram of the unite?

Simon.

moody9207 05-29-2012 11:35 AM

yes, it is on the back of the unit.


All times are GMT -7. The time now is 03:12 AM.

Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17