Problems with your Whirlpool Agitator?

Filed Under Washer Repair

There are a couple of issues that go on with many of the Whirlpool brand direct drive models, which include KitchenAid, Kenmore, and Inglis.  These issues include a clicking noise coming from the agitator and the agitator not having full movement during the wash cycle. 

There are cogs called “dogs” and a cam between the two halves of the agitator which can wear leading to the issues described above.  Once this happens, your washer will not clean as well as it is supposed to.   In most cases these worn parts can be replaced without much cost or difficulty.

All the parts needed for this repair are included in this Agitator Repair Kit:

Agitator Repair Kit

Agitator Breakdown

The top section(clothes mover) of the two piece agitator is removed by first pulling off the agitator cap then removing the inner cap. Underneath those there is usually a 7/16″ bolt which will need to be unscrewed. Once removed, the top agitator half can usually be pulled straight up to access the agitator kit components.

At this point you can make the repair of the defective parts.


Comments

6 Responses to “Problems with your Whirlpool Agitator?”

  1. brian perkin on May 2nd, 2008 9:23 pm

    what would cause a washer machine to leave oil spots on clothes? and best place to get parts. Thanks

  2. Chuck on May 18th, 2008 7:51 am

    How do you get the innercap off. My agiator wobbels would this kit fix that problem?If I could get the inner cap offI may be able to see what is worm. Thank you Chuck

  3. steve on June 15th, 2008 1:32 pm

    The clicking noise you speak of. The tub fills up and then makes a funny clicking noise. The tub does drain when you get to the end, but at the start just make a fast tempo clicking. Is this the noise you speak of in repairing with agitator kit?

    Thank You Steve

  4. David W. Salisbury on July 4th, 2008 5:28 pm

    Received parts and followed instructions and everything is alright and working well. Fast information and fast delivery. Will do business again if needed.

  5. David W. Salisbury on July 4th, 2008 5:32 pm

    Great direction’s and delivery was here within 3 days. Can’t ask for better service and direction’s. Thank you again and will use you again in the future if needed.

    Dave.

  6. Tom on July 8th, 2008 6:34 pm

    Just installed your Whirlpool agitator repair kit, took 10 minutes and works fantastic again. Thank you for fast and inspection service.
    Tom

Leave a Reply