View Single Post
  #4 (permalink)  
Old 07-25-2013, 03:09 PM
HumboldtRepairMan HumboldtRepairMan is offline
Senior Member
 
Join Date: Jul 2013
Posts: 916
HumboldtRepairMan is on a distinguished road
Default

Try "Affresh" tub tablets they work great for your problem.......Tide washtub cleaner doesn't work for nothing except smelling good i've field tested it and have seen units covered in mildew even after using Tide. Also google search mildew washer smell front loaders you'll have 4.5 billion complaints they know it's a problem since they invented them. The new GE washers have a pc clock type fan in the units now and they call it "overnight dry" or something like that as a sales pitch but in actuality it's a cure for letting the machines breath and get rid of the mold smell. Keep the door open and open the soap dispensor also when not it use this well help with drying out the tub. The GE you have may have a recall issue with the programming in the main board just recently they've been having us upload new software via modem box because they had issue with software malfunctions not spinning or draining out clothes properly.....Contact GE with your model and serial number and see if your's fits in that recall and voice your opinions about your complaint. Messing with the pressure switch doesn't really do much when it comes to washing with old water almost every single unit goes into a drain function first before it allows the new cycle to begin so it doesn't use the old water but i'm sure there may be a little remnant of water in the base of the unit because the pumps aren't strong enough to empty every drop. Good luck
Reply With Quote
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17