View Single Post
  #1 (permalink)  
Old 12-30-2012, 05:37 PM
Maytag52 Maytag52 is offline
Junior Member
Join Date: Dec 2012
Posts: 2
Maytag52 is on a distinguished road
Default Maytag MGDB800VQ0 Gas steam dryer won't start
Brand: Maytag   Age: 1 - 5 years   

Appliance Parts from

Ok, let me start and say I have a Maytag Bravos 400 series MGDB800VQ0 Stream model dryer. Which seemed to be doing ok. Itís 1.5 yrs old. We was running it when we got hit with a electrical surge. Seem a tree took down the high voltage line that feeds the transformers on the poles. We did not realize it for 2 days. Even then I seen a code on the little display and pushed the power button to turn it off. Wasnít till later wife said it would not start. Im a electrician and work on a lot of thing electronic but this giving me fits.. So in a nut shell. At first if I pushed the power or any button or open the door the system comes up with a ding. And diff lites come on , as I rotate the dial diff little lites on the side change to on and off and on. And the if the door is open lite is on inside. There is NO Time being displayed on the little panel to the left side. At best might get I think 3 bars. If I close the door , lite goes out and I push the start and hold it .. nothing. I tried diff thinks I seen on internet. Unplug 30 sec , and all. Nothing seemed to matter. If I pushed the drum lite on from the panel the lite never comes on. I finally found the tech sheet under the control panel and started the diagnostics, well as best as it would, press the button and release as it states. Then all the lites comes on for a bit and then go off and never come back on at all. If I continued to press the same button a couple of times checking for codes, I got a CO on the display. Which I have no idea what that is. And that all it wrote , had to clear it out to do anything. Seem nothing I did would not wortk as it said on that sheet. So I took a chance and got a replacement control board W10111620. Came today. Excited I plugged it in and for the most aprt , acted the same. But when I go to the diagnostics this time the lights came on then off for a bit then if I rem right the lights comes back and F 35 code flashes. But my sheet has nothing for a F 35 code. I looke and searched on the internet and the only code F 35 is for a analog stream thing for a WASHER. I tried the manual load test and it does not do anything. And there is where I am. Any idea's out there? Is my user interface bad? W10051114. About ready to shove it out the door and get a cheapo replace or a clothsline. Any help will be greatly appreciated. Gary

Reply With Quote
See inside of your appliance - diagrams and part photos for virtually every model.

powered by

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17